poj:2420 A Star not a Tree?(模拟退火算法)

这个题和poj2069  都是用%lf过不了  改成%f就能过

Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length. 
Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn't figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub. 

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won't move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

题意是给n个点,求出一个点距离其他所有点的距离之和最小

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#include<algorithm>
#define T 100
#define eps 1e-8
#define delta 0.98
#define INF 0x7fffffff
using namespace std;
typedef long long ll;
const int maxn = 1e3 + 5;

struct point {
	double x, y;
}p[maxn];
int tx[4] = {0, 0, -1, 1};
int ty[4] = {-1, 1, 0, 0};

double dis(point A, point B) {
	return sqrt((A.x - B.x) * (A.x - B.x) + (A.y - B.y) * (A.y - B.y));
}

double GetSum(int n, point t) {
	double ans = 0;
	for (int i = 0; i < n; i++)
		ans += dis(t, p[i]);
	return ans;
}

double Search(int n) {
	point s = p[0];
	double t = T;//初始化温度
	double ans = INF;
	while (t > eps) {
		int flag = 1;
		while (flag) {
			flag = 0;
			for(int i = 0; i < 4; i++) {
				point temp;
				temp.x = s.x + tx[i] * t;
				temp.y = s.y + ty[i] * t;
				double tp = GetSum(n, temp);
				if(ans > tp) {
					ans = tp;
					s = temp;
					flag = 1;
				}
			}
		}
		t *= delta;
	}
	return ans;
}

int main() {
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
		scanf("%lf%lf", &p[i].x, &p[i].y);
	double ans = Search(n);
	printf("%.0f\n", ans);
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值