Catch That Cow(BFS 剪枝 )

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4


#include <stdio.h>
#include <string.h>
#define maxi 10000000

bool vis[maxi];

struct node
{
    int x,t;
}que[maxi];

int bfs(int x,int k)
{
    int s=0,e=0;
    struct node tmp;
    que[e].x=x;
    que[e++].t=0;
    vis[x]=1;

    while(s!=e)
    {
        tmp=que[s++];
        if(tmp.x==k)
            return tmp.t;

        if(!vis[tmp.x+1]&&tmp.x<=k)
        {
            que[e].x=tmp.x+1;
            que[e++].t=tmp.t+1;
            e%=maxi;
            vis[tmp.x+1]=1;
        }
        if(!vis[tmp.x-1]&&tmp.x>=0)
        {
            que[e].x=tmp.x-1;
            que[e++].t=tmp.t+1;
            e%=maxi;
            vis[tmp.x-1]=1;
        }
        if(!vis[tmp.x*2]&&tmp.x<=k)
        {
            que[e].x=tmp.x*2;
            que[e++].t=tmp.t+1;
            e%=maxi;
            vis[tmp.x*2]=1;
        }
    }
}

int main()
{
    int n,k;
    scanf("%d%d",&n,&k);
    int ans=bfs(n,k);
    printf("%d\n",ans);

    return 0;


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值