Catch That Cow(剪枝防止超时)

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting. * Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute * Teleporting: FJ can move from any point X to the point 2 × X in a single minute. If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4

*由题意得,此题直接反应的是一颗度为三的树。遍历此树可得步数,但是如果不对树进行处理会超时;其他问题都很好想。

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
typedef struct node{
    int data;
    int ceng;
}Tree;
bool vis[100000];
queue <Tree > q;
int n,k;
void bfs(){
    Tree n;
    while(q.front().data!=k){
        int a=q.front().data;
        int b=q.front().ceng;
        n.data=a+1;
        n.ceng=b+1;
        if(n.data>=0&&n.data<=100000&&vis[n.data]==false){//这就是对数据的处理,将超出题目范围的节点和访问过得节点筛出。
        q.push(n);                                           //将结构体节点插入队列
        vis[n.data]=true;
        }
        n.data=a-1;
        n.ceng=b+1;
        if(n.data>=0&&n.data<=100000&&vis[n.data]==false){
        q.push(n);
        vis[n.data]=true;
        }
        n.data=a*2;
        n.ceng=b+1;
        if(n.data>=0&&n.data<=100000&&vis[n.data]==false){
        q.push(n);
        vis[n.data]=true;
        }
        q.pop();
    }
    cout<<q.front().ceng<<endl;
    return ;
    }
int main(){
    cin>>n>>k;
    Tree t;
    memset(vis,false,sizeof(vis));
    t.ceng=0;
    t.data=n;
    q.push(t);
    bfs();
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值