UVA - 10689 —— Yet another Number Sequence —— quickpow_Mat


Let’s define another number sequence, given by the following function:

f(0) = a

f(1) = b

f(n) = f(n − 1) + f(n − 2), n > 1

When a = 0 and b = 1, this sequence gives the Fibonacci Sequence. Changing the values of a andb, you can get many different sequences. Given the values of a, b, you have to find the last m digits off(n).

Input   The first line gives the number of test cases, which is less than 10001. Each test case consists of asingle line containing the integers a b n m. The values of a and b range in [0, 100], value of n ranges in[0, 1000000000] and value of m ranges in [1, 4].

Output   For each test case, print the last m digits of f(n).

However, you should NOT print any leading zero.

Sample Input  

4

0 1 11 3

0 1 42 4

0 1 22 4

0 1 21 4

Sample Output

89

4296

7711

946


#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <map>
#include <sstream>
#include <queue>
#include <stack>
#include <vector>
using namespace std;

#define INF 0x3f3f3f3f
#define Mem(a,x) memset(a,x,sizeof(x))
#define For(i,a,b) for(int i = a; i<b; i++)
#define ll long long
#define MAX_N 100010

typedef vector<int> vec;
typedef vector<vec> mat;
int m;
int mod[4] = {10,100,1000,10000};
mat mul(mat &A,mat &B)
{
    mat C(A.size(),vec(B[0].size()));
    for(int i = 0; i<A.size(); i++)
    {
        for(int k = 0; k<B.size(); k++)
        {
            for(int j = 0; j<B[0].size(); j++)
            {
                C[i][j] = C[i][j] + A[i][k]*B[k][j];
                C[i][j] %= mod[m-1];
            }
        }
    }
    return C;
}
mat pow(mat A,ll n)
{
    mat B(A.size(),vec(A.size()));
    for(int i = 0; i<A.size(); i++)
        B[i][i] = 1;
    while(n > 0)
    {
        if(n & 1) B = mul(B,A);
        A = mul(A,A);
        n >>= 1;
    }
    return B;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int x[10];
        Mem(x,0);
        int a,b;
        ll n;
        scanf("%d%d%lld%d",&a,&b,&n,&m);
        mat A(2,vec(2));
        A[0][0] = 1,A[0][1] = 1;
        A[1][0] = 1,A[1][1] = 0;
        A = pow(A,n);
        mat ans(2,vec(1));
        ans[0][0] = b,ans[1][0] = a;
        ans = mul(A,ans);
        printf("%d\n",ans[1][0]);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
磁共振成像(MRI)是一种医学影像技术,使用强磁场和无害的无线电波来生成身体内部的详细图像。其工作原理基于基本的物理原理和一系列的脉冲序列。 MRI的物理原理主要涉及到原子的磁性和自旋概念。人体组织中的大部分原子都具有自旋,即自身带有角动量。在磁场中,原子的自旋会与磁场方向相同或相反地排列。当磁场发生改变时,原子的自旋也会发生改变。利用这种自旋特性,可以通过对原子进行刺激来生成可视化的图像。 MRI的序列设计是基于脉冲的概念。在脉冲序列中,通过特定的时间和能量设置,可控制原子的自旋状态。常见的MRI序列包括T1加权序列和T2加权序列。T1加权序列通过使组织中的水分子在外加磁场作用下的自旋状态恢复到平衡来生成图像,用于显示解剖结构。T2加权序列则通过使组织中的水分子的自旋状态相互之间的松弛时间延迟来生成图像,用于显示水分子在组织中的分布和性质。 在MRI扫描过程中,患者将被放置在一个强大的磁场中,通常是静止的或移动的。无线电波将被用来刺激患者体内的原子自旋,并通过检测其自旋响应来生成图像。生成的图像可以提供关于组织结构、病变和功能信息。 总结来说,MRI的物理原理涉及到原子的磁性和自旋概念,利用无线电波来刺激原子自旋并生成可视化的图像。脉冲序列的设计用于控制原子自旋状态和生成不同类型的图像。通过深入理解MRI的物理原理和序列设计,可以更好地应用和解读MRI图像,为医学诊断和研究提供帮助。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值