SDUT_2116 数据结构实验之链表一:顺序建立链表

点击打开链接

数据结构实验之链表一:顺序建立链表

Time Limit: 1000MS  Memory Limit: 65536KB
Problem Description
输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。
Input
第一行输入整数的个数N;
第二行依次输入每个整数。
Output
输出这组整数。
Example Input
8
12 56 4 6 55 15 33 62
Example Output
12 56 4 6 55 15 33 62
Hint
#include <iostream>
using namespace std;
struct node
{
	int num;
	node *next;
};
int main()
{
	int n;
	node *head,*tail,*p;
	head=new node;
	head->next=NULL;
	tail=head;
	cin>>n;
	for(int i=0;i<n;i++)
	{
		p=new node;
		cin>>p->num;
		p->next=NULL;
		tail->next=p;
		tail=p;
	}
	node *q;
	q=new node;
	q=head->next;
	while(q!=NULL)
	{
		if(q->next!=NULL)
			cout<<q->num<<' ';
		else
			cout<<q->num<<endl;
		q=q->next;
	}
	return 0;
}

/***************************************************
User name: YT1658506207邵雪源
Result: Accepted
Take time: 0ms
Take Memory: 208KB
Submit time: 2017-08-02 12:37:40
****************************************************/


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值