UVa 10341 Solve It (牛顿法解超越方程)

10341 - Solve It

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=1282

Solve the equation:
        p*e-x q*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: pqrst and u (where0 <= p,r <= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution
0.7554

参考:维基百科——牛顿法

注意:

1. 根据系数的范围知道方程左端是递减的。(可以使用零点定理)

2. 如果f'(x)不为0, 那么牛顿法将具有平方收敛的性能.。粗略的说,这意味着每迭代一次,牛顿法结果的有效数字将增加一倍。


PS:你也可以用二分法,只不过慢一点而已。


完整代码:

/*0.019s*/

#include <cstdio>
#include <cmath>

int p, q, r, s, t, u;
double x;

inline double fun(double x)
{
	return p * exp(-x) + q * sin(x) + r * cos(x) + s * tan(x) + t * x * x + u;
}

///导数
inline double fun2(double x)
{
	return -p * exp(-x) + q * cos(x) - r * sin(x) + s / (cos(x) * cos(x)) + 2 * t * x;
}

int main(void)
{
	while (~scanf("%d%d%d%d%d%d", &p, &q, &r, &s, &t, &u))
	{
		double x1 = fun(0.0), x2 = fun(1.0);
		if (x1 == 0)
		{
			puts("0.0000");
			continue;
		}
		if (x2 == 0)
		{
			puts("1.0000");
			continue;
		}
		if (x1 * x2 > 0)
		{
			puts("No solution");
			continue;
		}
		x = 0.5;///从0.5开始
		double tmp = 0.0;
		while (fabs(x - tmp) > 1e-3)///想保险点的话可以写1e-6(保两位)
		{
			tmp = x;
			x -= fun(x) / fun2(x);
		}
		printf("%.4f\n", x);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值