UVa 10098 Generating Fast (全排列生成)

262 篇文章 0 订阅
49 篇文章 0 订阅

10098 - Generating Fast

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=onlinejudge&page=show_problem&problem=1039

Generating permutation has always been an important problem in computer science. In this problem you will have to generate the permutation of a given string in ascending order.  Remember that your algorithm must be efficient.


Input

The first line of the input contains an integer n, which indicates how many strings to follow. The next n lines contain n strings. Strings will only contain alpha numerals and never contain any space. The maximum length of the string is 10.

 
Output

For each input string print all the permutations possible in ascending order. Not that the strings should be treated, as case sensitive strings and no permutation should be repeated. A blank line should follow each output set.

 

Sample Input

3
ab
abc
bca

 

Sample Output

ab
ba

abc
acb
bac
bca
cab
cba

abc
acb
bac
bca
cab
cba


STL算法搞定。


完整代码:

/*0.042s*/

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

char str[15];

int main(void)
{
	int t, len;
	scanf("%d\n", &t);
	while (t--)
	{
		gets(str);
		len = strlen(str);
		sort(str, str + len);
		do
			puts(str);
		while (next_permutation(str, str + len));///此方法不会重复输出
		putchar('\n');
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值