UVa 10061 How many zero's and how many digits ? (任意进制下的阶乘长度和尾0的数目)

10061 - How many zero's and how many digits ?

Time limit: 20.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=100&page=show_problem&problem=1002

Given a decimal integer number you will have to find out how many trailing zeros will be there in its factorial in a given number system and also you will have to find how many digits will its factorial have in a given number system? You can assume that for a b based number system there are b different symbols to denote values ranging from 0 ... b-1.


Input

There will be several lines of input. Each line makes a block. Each line will contain a decimal number N (a 20bit unsigned number) and a decimal number B (1<B<=800), which is the base of the number system you have to consider. As for example 5! = 120 (in decimal) but it is 78 in hexadecimal number system. So in Hexadecimal 5! has no trailing zeros


Output

For each line of input output in a single line how many trailing zeros will the factorial of that number have in the given number system and also how many digits will the factorial of that number have in that given number system. Separate these two numbers with a single space. You can be sure that the number of trailing zeros or the number of digits will not be greater than 2^31-1


Sample Input:

2 10
5 16
5 10

 

Sample Output:

0 1
0 2
1 3


【思路】

尾零的数目怎么求?

在普通的10进制下,计算N!后面有多少个0,就要考虑N!的素因子分解中5的幂次就行了(因为10=2*5且5的幂次恒<=2的幂次)

受此启发,在其他进制中,考虑base质因子分解中最大质数maxp的幂次和n质因子分解中maxp的幂次就行。


完整代码:

/*0.075s*/

#include <cstdio>
#include <cmath>
const int maxn = 1 << 20;

double digit[maxn];

///当有太多重复运算时,不妨打表
inline void lenN()
{
	for (int i = 1; i < maxn; i++)
		digit[i] = digit[i - 1] + log(i);
}

int main()
{
	lenN();
	int n, n2, base, base2, maxp, rn, rbase;
	while (~scanf("%d%d", &n, &base))
	{
		n2 = n, base2 = base;
		maxp = 1;
		for (int i = 2; i <= base; ++i)
		{
			rbase = 0;
			while (base % i == 0)
			{
			    maxp = i;///最大质数
				++rbase;///base质因子分解中最大质数的幂次
				base /= i;
			}
		}
		rn = 0;
		while (n)
		{
		    n /= maxp;
			rn += n;///n质因子分解中maxp的幂次
		}
		///万一算出来个xxx.9999999999怎么办?精度微调必不可少!
		printf("%d %d\n", rn / rbase, (int)(digit[n2] / log(base2) + 1e-9) + 1);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值