UVa 10921 Find the Telephone (water ver.)

10921 - Find the Telephone

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=24&page=show_problem&problem=1862

In some places is common to remember a phone number associating its digits to letters. In this way the expression MY LOVE means 69 5683. Of course there are some problems, because some phone numbers can not form a word or a phrase and the digits 1 and 0 are not associated to any letter.

Your task is to read an expression and find the corresponding phone number based on the table below. An expression is composed by the capital letters (A-Z), hyphens (-) and the numbers 1 and 0.

LettersNumber
ABC2
DEF3
GHI4
JKL5
MNO6
PQRS7
TUV8
WXYZ9

Input

The input consists of a set of expressions. Each expression is in a line by itself and has C characters, where 1 ≤ C ≤ 30. The input is terminated by enf of file (EOF).

Output

For each expression you should print the corresponding phone number.

Sample Input

1-HOME-SWEET-HOME
MY-MISERABLE-JOB

Sample Output

1-4663-79338-4663
69-647372253-562


完整代码:

/*0.018s*/

#include<cstdio>
#include<cctype>
#include<cstring>
const char num[] = {" 22233344455566677778889999"};

char str[35];

int main()
{
	int len, i;
	while (gets(str))
	{
		len = strlen(str);
		for (i = 0; i < len; ++i)
			putchar(isalpha(str[i]) ? num[str[i] & 31] : str[i]);
		putchar(10);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值