UVa 861 Little Bishops (组合数学)

861 - Little Bishops

Time limit: 3.000 seconds

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=36&page=show_problem&problem=802

A bishop is a piece used in the game of chess which is played on a board of square grids. A bishop can only move diagonally from its current position and two bishops attack each other if one is on the path of the other. In the following figure, the dark squares represent the reachable locations for bishop B1 form its current position.  The figure also shows that the bishops B1 and B2 are in attacking positions whereas B1 andB3 are not. B2 and B3 are also in non-attacking positions.

 

 

Now, given two numbers n and k, your job is to determine the number of ways one can put k bishops on an n × n chessboard so that no two of them are in attacking positions.

 

Input

 The input file may contain multiple test cases. Each test case occupies a single line in the input file and contains two integers n (1 ≤ n ≤ 8) and k(0 ≤ k ≤ n2).

 

A test case containing two zeros for n and k terminates the input and you won’t need to process this particular input.

 

Output

For each test case in the input print a line containing the total number of ways one can put the given number of bishops on a chessboard of the given size so that no two of them are in attacking positions. You may safely assume that this number will be less than 1015.

 

Sample Input
8 6
4 4
0 0

 

Sample Output
5599888
260


思路:(下面的行数指斜着看时的对角线的“行数”。)

1. 枚举象放在白格和黑格上的数目:sum{ Rb[n][i] * Rw[n - 1][k - i] } (斜着看,Rb[i][j]表示在前 i 行的黑格上放置 j 个车而互不冲突的方法,Rw[i][j]表示在前 i 行的白格上放置 j 个车而互不冲突的方法)

2. 如何计算Rb[i][j]和Rw[i][j]?

以Rb为例,也斜着看,因为每一行只能放置一个车,则 j 个车要么全在前 i - 1 行,要么第 i 行有一个。j 个车全在前 i - 1 行的放置方法为 Rb[i - 1][j];若第 i 行放置一个车,则前 i - 1 行放置 j - 1 个车,那么前 i - 1 行在放置 j - 1 个车时已经占用了第 i 行的 j - 1 个格子,剩余的格子数为 B[i] - (j - 1)  (B[i]是第i行的黑格数)

则得到递推式:Rb[i][j] = Rb[i - 1][j] + Rb[i - 1][j - 1] * (B[i] - (j - 1))


完整代码:

/*0.015s*/

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
const int M = 8 + 5;
const int N = 8 * 8 + 5;

ll Rb[M][N], Rw[M][N], B[M], W[M]; ///B=Black, W=White

void calc(int n, int k, ll R[][N], ll C[])
{
	int i, j;
	memset(R, 0, sizeof(R));
	for (i = 0; i <= n; i++)
		R[i][0] = 1;
	for (i = 1; i <= n; i++)
		for (j = 1; j <= C[i]; j++)
			R[i][j] = R[i - 1][j] + R[i - 1][j - 1] * (C[i] - j + 1);
}

int main()
{
	int i, j, n, k;
	ll ans;
	while (scanf("%d%d", &n, &k), n)
	{
		memset(B, 0, sizeof(B));
		memset(W, 0, sizeof(W));
		for (i = 1; i <= n; i++)
			for (j = 1 ; j <= n; j++)
			{
				if ((i + j) & 1) ++W[(i + j) >> 1];
				else ++B[(i + j) >> 1]; ///计算黑和白的对角线格子数,这样写就不用考虑n的奇偶性
			}
		sort(B + 1, B + n + 1);
		sort(W + 1, W + n);
		calc(n, k, Rb, B);
		calc(n - 1, k, Rw, W);///分别计算白格和黑格上的方案数
		ans = 0;
		for (i = 0; i <= k; i++)
			ans += Rb[n][i] * Rw[n - 1][k - i];
		printf("%lld\n", ans);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值