禁止yum update 自动更新系统内核

使用yum update更新系统软件时,禁止升级内核,可以防止产生因不兼容导致的未知错误。

设置前请先备份原设置文件yum.conf

cp /etc/yum.conf    /etc/yum.conf.bak

两种方法:

方法一(永久解决,一劳永逸):

修改yum的配置文件 vim /etc/yum.conf  

在[main]的最后添加 exclude=kernel*

注意上面  kernel后面有*号,表示所有 kernel开头的.....

方法二:

直接在yum的命令后面加上  --exclude=kernel*  参数,如下:

yum --exclude=kernel* update

展开阅读全文

没有更多推荐了,返回首页