08-图8 How Long Does It Take

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i]E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".

Sample Input 1:

9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4

Sample Output 1:

18

Sample Input 2:

4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5

Sample Output 2:

Impossible
//
//  main.cpp
//  8-2 How long does it take
//
//  Created by 佘一夫 on 15/11/19.
//  Copyright © 2015年 佘一夫. All rights reserved.
//

#include <iostream>
#include <queue>
using namespace std;
#define MaxVertexNum 100
#define INF 9999
#define max(a,b) a>b?a:b

typedef struct Graph *MGraph;
struct Graph
{
    int G[MaxVertexNum][MaxVertexNum];
    int Nv;
    int Ne;
    
};

MGraph CreateGraph()
{
    MGraph Gra=new(Graph);
    cin>>Gra->Nv>>Gra->Ne;
    for (int i=0; i<Gra->Nv; ++i)
    {
        for (int k=0; k<Gra->Nv; ++k)
        {
            Gra->G[i][k]=-1;
        }
    }
    return Gra;
}

MGraph BuildGraph(MGraph Gra,int InDegree[],int Cost[])
{
    int row,lie,cost;
    for (int i=0; i<Gra->Ne; ++i)
    {
        cin>>row>>lie>>cost;
        Gra->G[row][lie]=cost;
        InDegree[lie]++;
        Cost[lie]=max(cost,Cost[lie]);
    }
    return Gra;
}

void ToplogicalSort(MGraph Gra,int InDegree[],int Cost[])
{
    queue<int> Q;
    int count=0;
    int temp;
    
    for (int i=0; i<Gra->Nv; ++i)
    {
        if (!InDegree[i])
        {
            Q.push(i);
        }
    }
    
    while (!Q.empty())
    {
        temp=Q.front();
        Q.pop();
        count++;
        
        for (int i=0; i<Gra->Nv; ++i)
        {
            if (Gra->G[temp][i]!=-1)
            {
                if (--InDegree[i]==0)
                {
                    Q.push(i);
                }
                if ((Cost[temp]+Gra->G[temp][i])>Cost[i])
                {
                    Cost[i]=Cost[temp]+Gra->G[temp][i];
                }
            }
        }
    }
    
        if (count==Gra->Nv)
        {
            temp=0;
            for (int i=0; i<Gra->Nv; ++i)
            {
                temp=max(Cost[i],temp);
            }
            cout<<temp;
        }else
        {
            cout<<"Impossible";
        }
    
}

int main(int argc, const char * argv[])
{
    MGraph Gra=CreateGraph();
    int InDegree[MaxVertexNum]={};
    int Cost[MaxVertexNum]={};
    Gra=BuildGraph(Gra, InDegree, Cost);
    ToplogicalSort(Gra, InDegree, Cost);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值