HDU 3332 Windows

Emma is not very tidy with the desktop of her computer. She has the habit of opening windows on the screen and then not closing the application that created them. The result, of course, is a very cluttered desktop with some windows just peeking out from behind others and some completely hidden. Given that Emma doesn’t log off for days, this is a formidable mess. Your job is to determine which window (if any) gets selected when Emma clicks on a certain position of the screen. 

Emma’s screen has a resolution of 10  6 by 10  6. When each window opens its position is given by the upper-left-hand corner, its width, and its height. (Assume position (0,0) is the location of the pixel in the upper-left-hand corner of her desktop. So, the lower-right-hand pixel has location (999999, 999999).)
Input
Input for each test case is a sequence of desktop descriptions. Each description consists of a line containing a positive integer  n, the number of windows, followed by  n lines,  n ≤ 100, describing windows in the order in which Emma opened them, followed by a line containing a positive integer  m, the number of queries, followed by  m lines, each describing a query. Each of the  n window description lines contains four integers  r, c, w, and  h, where (  r, c) is the row and column of the upper left pixel of the window, 0 ≤  r, c ≤ 999999, and  w and  h are the width and height of the window, in pixels, 1 ≤ w, h. All windows will lie entirely on the desktop (i.e., no cropping). Each of the  m query description lines contains two integers  cr and  cc, the row and column number of the location (which will be on the desktop). The last test case is followed by a line containing 0.
Output
Using the format shown in the sample, for each test case, print the desktop number, beginning with 1, followed by  m lines, one per query. The  i-th line should say either “window  k”, where  k is the number of the window clicked on, or “background” if the query hit none of the windows. We assume that windows are numbered consecutively in the order in which Emma opened them, beginning with 1. Note that querying a window does not bring that window to the foreground on the screen.
Sample Input
3
1 2 3 3
2 3 2 2
3 4 2 2
4
3 5
1 2
4 2
3 3
2
5 10 2 10
100 100 100 100
2
5 13
100 101
0
Sample Output
Desktop 1:
window 3
window 1
background
window 2
Desktop 2:
background
window 2

pixel是像素的意思,是块不是一个点。但可以转换成点。


这就简单了,我首先想到的是用map,但超时了,后来用链表做的,注意释放内存,不然会答案错误。最简单的方法是用线性表,因为题目里说了n<=100,也就是说不会超过100个数据。

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<time.h>
using namespace std;
struct Node
{
    int x,y;
    int x1,y1;
    int g;
    Node*next;
};
int main()
{
    int n,m;
    int x,y,w,h;

    Node* p;

    int cnt=0;
    while(~scanf("%d",&n)&&n)
    {
        //clock_t beg=clock();
        cnt++;
        Node* L=(Node*)malloc(sizeof(Node));
        L->next=NULL;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d%d",&x,&y,&w,&h);
            Node*s=(Node*)malloc(sizeof(Node));
            s->g=i;
            s->x1=x+h-1;
            s->y1=y+w-1;
            s->x=x;
            s->y=y;
            s->next=L->next;
            L->next=s;
        }
        scanf("%d",&m);
        int flag=0;
        printf("Desktop %d:\n",cnt);
        while(m--)
        {
            scanf("%d%d",&x,&y);
            p=L->next;
            flag=0;
            while(p!=NULL)
            {
                //printf("*******%d\n",p->g);
                if(p->x<=x&&p->x1>=x&&p->y<=y&&p->y1>=y)
                {
                    printf("window %d\n",p->g);
                    flag=1;
                    break;
                }
                 p=p->next;

            }
            if(flag==0)
            {
                printf("background\n");
            }
        }
        Node *pre=L;
        p=L->next;
        while(p!=NULL)
        {
            free(pre);
            pre=p;
            p=p->next;
        }
        free(pre);
        //clock_t end=clock();
        //cout<<"runtime="<<end-beg<<endl;
    }


    return 0;
}


Description Emma is not very tidy with the desktop of her computer. She has the habit of opening windows on the screen and then not closing the application that created them. The result, of course, is a very cluttered desktop with some windows just peeking out from behind others and some completely hidden. Given that Emma doesn’t log off for days, this is a formidable mess. Your job is to determine which window (if any) gets selected when Emma clicks on a certain position of the screen. Emma’s screen has a resolution of 106 by 106. When each window opens its position is given by the upper-left-hand corner, its width, and its height. (Assume position (0,0) is the location of the pixel in the upper-left-hand corner of her desktop. So, the lower-right-hand pixel has location (999999, 999999).) Input Input for each test case is a sequence of desktop descriptions. Each description consists of a line containing a positive integer n, the number of windows, followed by n lines, n ≤ 100, describing windows in the order in which Emma opened them, followed by a line containing a positive integer m, the number of queries, followed by m lines, each describing a query. Each of the n window description lines contains four integers r, c, w, and h, where (r, c) is the row and column of the upper left pixel of the window, 0 ≤ r, c ≤ 999999, and w and h are the width and height of the window, in pixels, 1 ≤ w, h. All windows will lie entirely on the desktop (i.e., no cropping). Each of the m query description lines contains two integers cr and cc, the row and column number of the location (which will be on the desktop). The last test case is followed by a line containing 0. Output Using the format shown in the sample, for each test case, print the desktop number, beginning with 1, followed by m lines, one per query. The i-th line should say either “window k”, where k is the number of the window clicked on, or “background” if the query hit none of the windows. We assume that windows are numbered consecutively in the order in which Emma opened them, beginning with 1. Note that querying a window does not bring that window to the foreground on the screen. Sample Input 3 1 2 3 3 2 3 2 2 3 4 2 2 4 3 5 1 2 4 2 3 3 2 5 10 2 10 100 100 100 100 2 5 13 100 101 0 Sample Output Desktop 1: window 3 window 1 background window 2 Desktop 2: background window 2
在探索智慧旅游的新纪元中,一个集科技、创新与服务于一体的整体解决方案正悄然改变着我们的旅行方式。智慧旅游,作为智慧城市的重要分支,旨在通过新一代信息技术,如云计算、大数据、物联网等,为游客、旅游企业及政府部门提供无缝对接、高效互动的旅游体验与管理模式。这一方案不仅重新定义了旅游行业的服务标准,更开启了旅游业数字化转型的新篇章。 智慧旅游的核心在于“以人为本”,它不仅仅关注技术的革新,更注重游客体验的提升。从游前的行程规划、信息查询,到游中的智能导航、个性化导览,再到游后的心情分享、服务评价,智慧旅游通过构建“一云多屏”的服务平台,让游客在旅游的全过程中都能享受到便捷、个性化的服务。例如,游客可以通过手机APP轻松定制专属行程,利用智能语音导览深入了解景点背后的故事,甚至通过三维GIS地图实现虚拟漫游,提前感受目的地的魅力。这些创新服务不仅增强了游客的参与感和满意度,也让旅游变得更加智能化、趣味化。 此外,智慧旅游还为旅游企业和政府部门带来了前所未有的管理变革。通过大数据分析,旅游企业能够精准把握市场动态,实现旅游产品的精准营销和个性化推荐,从而提升市场竞争力。而政府部门则能利用智慧旅游平台实现对旅游资源的科学规划和精细管理,提高监管效率和质量。例如,通过实时监控和数据分析,政府可以迅速应对旅游高峰期的客流压力,有效预防景区超载,保障游客安全。同时,智慧旅游还促进了跨行业、跨部门的数据共享与协同合作,为旅游业的可持续发展奠定了坚实基础。总之,智慧旅游以其独特的魅力和无限潜力,正引领着旅游业迈向一个更加智慧、便捷、高效的新时代。
内容概要:本文详细介绍了大模型的发展现状与未来趋势,尤其聚焦于DeepSeek这一创新应用。文章首先回顾了人工智能的定义、分类及其发展历程,指出从摩尔定律到知识密度提升的转变,强调了大模型知识密度的重要性。随后,文章深入探讨了DeepSeek的发展路径及其核心价值,包括其推理模型、思维链技术的应用及局限性。此外,文章展示了DeepSeek在多个行业的应用场景,如智能客服、医疗、金融等,并分析了DeepSeek如何赋能个人发展,具体体现在公文写作、文档处理、知识搜索、论文写作等方面。最后,文章展望了大模型的发展趋势,如通用大模型与垂域大模型的协同发展,以及本地部署小模型成为主流应用渠道的趋势。 适合人群:对人工智能和大模型技术感兴趣的从业者、研究人员及希望利用DeepSeek提升工作效率的个人用户。 使用场景及目标:①了解大模型技术的最新进展和发展趋势;②掌握DeepSeek在不同领域的具体应用场景和操作方法;③学习如何通过DeepSeek提升个人在公文写作、文档处理、知识搜索、论文写作等方面的工作效率;④探索大模型在特定行业的应用潜力,如医疗、金融等领域。 其他说明:本文不仅提供了理论知识,还结合实际案例,详细介绍了DeepSeek在各个场景下的应用方式,帮助读者更好地理解和应用大模型技术。同时,文章也指出了当前大模型技术面临的挑战,如模型的局限性和数据安全问题,鼓励读者关注技术的持续改进和发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值