二叉树求先序和后序模板

给出一棵二叉树的中序与后序排列。求出它的先序排列。(约定树结点用不同的大写字母表示,长度

8
)。

输入格式
2
行,均为大写字母组成的字符串,表示一棵二叉树的中序与后序排列。

输出格式
1
行,表示一棵二叉树的先序。

Sample Input
BADC
BDCA
Sample Output
ABCD

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char s1[100],s2[100];
void w(int a1,int b1,int a2,int b2)
{
    int k=-1;
    for(int i=a1;i<b1;i++)
    {
        if(s1[i]==s2[b2-1])
        {
            printf("%c",s1[i]);
            k=i;
            break;
        }
    }
    if(k>a1)
    w(a1,k,a2,k-a1+a2);
    if(b1>k+1)
        w(k+1,b1,k-a1+a2,b2-1);
}
int main()
{
    scanf("%s %s",s1,s2);
    int l1=strlen(s1);
    int l2=strlen(s2);
    w(0,l1,0,l2);
    return 0;
}

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
Output
For each test case print a single line specifying the corresponding postorder sequence.
Sample Input
9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6
Sample Output
7 4 2 8 9 5 6 3 1

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[10000],b[10000],n;
void dfs(int l1,int r1,int x,int flag)
{
    int i;
    if(x<=0)
        return ;
    for(i=0;a[l1]!=b[r1+i];i++);
    dfs(l1+1,r1,i,0);
    dfs(l1+i+1,r1+i+1,x-i-1,0);
    if(flag)
        printf("%d",a[l1]);
    else
        printf("%d ",a[l1]);
}
int main()
{
    while(~scanf("%d",&n))
    {
    for(int i=0;i<n;i++)
    scanf("%d",&a[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&b[i]);
    dfs(0,0,n,1);
    printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值