莫队

Given an array of N integers indexed from 1 to N, and q queries, each in the form i j, you have to find the number of distinct integers from index i to j (inclusive).

Input
Input starts with an integer T (≤ 5), denoting the number of test cases.

The first line of a case is a blank line. The next line contains two integers N (1 ≤ N ≤ 105), q (1 ≤ q ≤ 50000). The next line contains N space separated integers forming the array. There integers range in [0, 105].

Each of the next q lines will contain a query which is in the form i j (1 ≤ i ≤ j ≤ N).

Output
For each test case, print the case number in a single line. Then for each query you have to print a line containing number of distinct integers from index i to j.

Sample Input
1

8 5
1 1 1 2 3 5 1 2
1 8
2 3
3 6
4 5
4 8
Sample Output
Case 1:
4
1
4
2
4

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct node
{
    int l,r;
    int id;
}h[6000000];
int a[6000000];
int cnt[6000000];
int sum[6000000];
int ans,block;
bool cmp(node x,node y)
{
    if((x.l/block)==(y.l/block))//左端点位于同一个快
    {
        if((x.l/block)%2)//左端点序号为奇数时
        return x.r<y.r;//按照从小到大
        else//左端点为偶数
        return x.r>y.r;//按照从小到大
    }
    return x.l<y.l;//按照快的位置排序
}
void add(int x)
{
    cnt[x]++;
    if(cnt[x]==1)
        ans++;
}
void move(int x)
{
    cnt[x]--;
    if(!cnt[x])
    ans--;
}
int main()
{
    int t,n,m,k=1;;
    scanf("%d",&t);
    while(t--)
    {
        memset(cnt,0,sizeof(cnt));
        ans=0;
        scanf("%d%d",&n,&m);
        block=sqrt(n*1.0);
        for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
        for(int i=1;i<=m;i++)
        {
         scanf("%d%d",&h[i].l,&h[i].r);
         h[i].id=i;
        }
        sort(h+1,h+m+1,cmp);
        int l=1,r=0;
        ans=0;
        for(int i=1;i<=m;i++)
        {
            while(l<h[i].l)move(a[l++]);
            while(l>h[i].l)add(a[--l]);
            while(r<h[i].r)add(a[++r]);
            while(r>h[i].r)move(a[r--]);
            sum[h[i].id]=ans;
        }
        printf("Case %d:\n",k++);
        for(int i=1;i<=m;i++)
        printf("%d\n",sum[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值