G-Good numbers

If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number. 
You are required to count the number of good numbers in the range from A to B, inclusive.
Input
The first line has a number T (T <= 10000) , indicating the number of test cases. 
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
Sample Input
2
1 10
1 20
Sample Output
Case #1: 0
Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.

题意大概就是 只要每位数上的数字加起来是十的倍数  就是好数字

直接规律就行了  从19开始  每10个数字里有一个。

#include<iostream>

using namespace std;
long long a,b,c,d,e,ans2;
int suma,sumb,sym;
long long sum( long long n)
{
    long long ans=0;
    while(n)
    {
        ans+=n%10;
        n/=10;
    }
    return ans;
}
int main()
{
int i,t,k,num;
while(cin>>t){
k=0;
while(t--){
cin>>a>>b;    
ans2=0;
suma=b%10;   
d=b/10;      
sumb=sum(d);   
num=(sumb+9)-(sumb+9)%10; 
if(suma>=(num-sumb))
ans2++;
suma=a%10;
d=a/10;
sumb=sum(d);
num=(sumb+9)-(sumb+9)%10;
if((suma>(num-sumb)&&(a>=10))||(a>0&&a<10))
ans2--;
c=b-b%10-a+a%10;
e=c/10;
ans2+=e;
cout<<"Case #"<<++k<<": "<<ans2<<endl;
}}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值