ZOJ1858 Soundex

map的基本应用。题目给出的字符对应不同的整数值,要你根据输入的字符串并按照其顺序输出每个字符对应的整数值。如果不是初始给定的字符便不进行处理。。。

本题唯一容易忽略的地方是:如果待翻译的字符串中多个相同的字符靠在一块,那么只输出一个。。。

ZOJ Problem Set - 1858
Soundex

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Soundex coding groups together words that appear to sound alike based on their spelling. For example, "can" and "khawn", "con" and "gone" would be equivalent under Soundex coding. 

Soundex coding involves translating each word into a series of digits in which each digit represents a letter:

1 represents B, F, P, or V
2 represents C, G, J, K, Q, S, X, or Z
3 represents D or T
4 represents L
5 represents M or N
6 represents R

The letters A, E, I, O, U, H, W, and Y are not represented in Soundex coding, and repeated letters with the same code digit are represented by a single instance of that digit. Words with the same Soundex coding are considered equivalent.


Input

Each line of input contains a single word, all upper case, less than 20 letters long.


Output

For each line of input, produce a line of output giving the Soundex code.


Sample Input

KHAWN
PFISTER
BOBBY


Sample Output

25
1236
11


Source:  University of Waterloo Local Contest 1999.09.2
#include <iostream>
#include <map>
#include <string>
using namespace std;

int main()
{
	string s;
	map<char,int> m;
	m['B']=m['F']=m['P']=m['V']=1;
	m['C']=m['G']=m['J']=m['K']=m['Q']=m['S']=m['X']=m['Z']=2;
	m['D']=m['T']=3;
	m['L']=4;
	m['M']=m['N']=5;
	m['R']=6;
	while(cin>>s)
	{
		for(int i=0;i<s.length();i++)
		{
			if(m[s[i]]!=0&&m[s[i]]!=m[s[i-1]])
			    cout<<m[s[i]];
		}
		cout<<endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值