poj 2528 Mayor's posters 线段树

                                                                                                                                        Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 50053 Accepted: 14536

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

第一道线段树,在题解的帮助下AC的。。。我惭愧。。。

题意:贴海报,看最后有多少海报可以看的到,哪怕只是一部分。

思路:用线段树表示每个区段贴的是第几张海报,最后用exi[i]=1表示该种海报存在且未被完全覆盖。

其实现在想想这道题是可以优化的,因为每次覆盖的最大的end不一定都是max2,也就是说,并不会是每次都要从根节点是1~max2开始往下找。 。。。

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int max1=50000010;
const int max2=10000010;
int exi[10010];
struct node{
    int id;
    int l,r;
    int stt,edd,mdd;
};
node tree[max1];
int root,ptr;
void get(int cr,int str,int end,int kinds){
    if(end<=str) return ;
    if(tree[cr].stt==str&&tree[cr].edd==end){
        tree[cr].id=kinds;
        return ;
    }

    int mid=(tree[cr].edd+tree[cr].stt)/2;
    if(tree[cr].l==0){
        tree[cr].l=ptr++;
        tree[tree[cr].l].edd=mid;
        tree[tree[cr].l].stt=tree[cr].stt;
        tree[tree[cr].l].id=-1;
        tree[tree[cr].l].l=0;
        tree[tree[cr].l].r=0;
    }
    if(tree[cr].r==0){
        tree[cr].r=ptr++;
        tree[tree[cr].r].edd=tree[cr].edd;
        tree[tree[cr].r].stt=mid;
        tree[tree[cr].r].id=-1;
        tree[tree[cr].r].l=0;
        tree[tree[cr].r].r=0;
    }
    if(tree[cr].id!=0){
        tree[tree[cr].l].id=tree[tree[cr].r].id=tree[cr].id;
        tree[cr].id=0;
    }

    if(str>=mid) {
        get(tree[cr].r,str,end,kinds);
        return;
    }
    if(end<=mid) {
        get(tree[cr].l,str,end,kinds);
        return;
    }
    get(tree[cr].l,str,mid,kinds);
    get(tree[cr].r,mid,end,kinds);
}
void res(int n){
    if(n==0||tree[n].id==-1) return;
    exi[tree[n].id]=1;
    if(tree[n].id!=0) return;
    res(tree[n].l);
    res(tree[n].r);
}
void init(){
    root=1;
    tree[root].l=0;
    tree[root].r=0;
    tree[root].id=0;//
    tree[root].stt=1;
    tree[root].edd=max2;
    tree[root].mdd=(1+max2)/2;
    ptr=2;
}
int main()
{
    int n;
    scanf("%d",&n);
        while(n--){
            init();
            int x,i,l,r;
            scanf("%d",&x);
            for(i=1;i<=x;i++){
                scanf("%d%d",&l,&r);
                get(1,l,r+1,i);
            }
            memset(exi,0,sizeof(exi));
            res(1);
            int ans=0;
            for(i=1;i<=x;i++){
                if(exi[i])ans++;
            }
            printf("%d\n",ans);
        }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值