POJ2528 Mayor's posters 线段树

Mayor's posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 49723 Accepted: 14419

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4
首先想到离散化,正确的离散化的方法:

即每条线段用这条线段所覆盖的单位区间的两端的区间表示,
如图中:线段①表示为:[1,4];线段②表示为:[2,6];线段③表示为:[3,4]。

离散后既对线段处理,我们可以把所以线段全部插入,然后再查询一次。
即染色问题
维护这样的信息
cover[k]:k对应的区间是否被同一种颜色完全染色。
颜色依次用1,2,3,...,n表示,初始是用0将区间全部
查询时用一个bool型数组vis,查询整个区间,遇见有什么颜色,就把该颜色的vis设为true,最后
统计一下,vis里true的个数即为答案。

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

//其实离散后总共的单位区间最多可达到20000+19999个
//所以cover开到maxn*2*2*4
const int maxn=10000+10;
int cover[maxn*16],x[maxn],y[maxn],s[maxn*2];
unsigned short Hash[10000005];      //unsigned short才够用,short不够用,会re

void pushDown(int k){
    if(cover[k]>=0){
        cover[k*2]=cover[k*2+1]=cover[k];
        cover[k]=-1;
    }
}

void Insert(int a,int b,int c,int k,int l,int r){
    if(a<=l && r<=b){
        cover[k]=c;return ;
    }
    pushDown(k);
    int m=(l+r)/2;
    if(a<=m)
        Insert(a,b,c,k*2,l,m);
    if(b>m)
        Insert(a,b,c,k*2+1,m+1,r);
}

bool vis[maxn];

void ask(int k,int l,int r){
    if(cover[k]>=0){
        vis[cover[k]]=true;
        return ;
    }
    if(l==r) return ;
    pushDown(k);
    int m=(l+r)/2;
    ask(k*2,l,m);
    ask(k*2+1,m+1,r);
}

int main()
{
    int i,T,n;
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);
        memset(Hash,0,sizeof(Hash));
        int tot=0;
        for(i=0;i<n;i++){
            scanf("%d%d",&x[i],&y[i]);
            if(Hash[x[i]]==0){
                s[tot++]=x[i];
                Hash[x[i]]++;
            }
            if(Hash[y[i]]==0){
                s[tot++]=y[i];
                Hash[y[i]]++;
            }
        }
        sort(s,s+tot);
        int m=1;
        for(i=0;i<tot;i++){
            Hash[s[i]]=m;
            if(i<tot-1){
                if(s[i+1]-s[i]==1)  //如果原坐标(x[],y[])是相邻的(即差值为1),那么离散后也是相邻的(即差值也为1)
                    m++;
                else
                    m+=2; //如果原坐标不是相邻的(即差值大于1),那么离散也不相邻,中间要隔一个单位区间(所以要加2)
            }
        }
        memset(cover,-1,sizeof(cover));
        cover[1]=0;
        for(i=0;i<n;i++)
            Insert(Hash[x[i]],Hash[y[i]],i+1,1,1,m);
        memset(vis,false,sizeof(vis));
        ask(1,1,m);
        int res=0;
        for(i=1;i<=n;i++)
            if(vis[i]) res++;
        printf("%d\n",res);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值