hdu 3336 Count the string kmp

Count the string

                          Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
  
  
1 4 abab
 

Sample Output
  
  
6
 

Author
foreverlin@HNU
   

题意:求出前n个字符组成的字符串能被原串匹配次数之和

如 ababababab

a=5

ab=5

aba=4

abab=4

ababa=3

ababab=3

abababa=2

abababab=2

ababababa=1

ababababab=1

sum=5+5+4+4+3+3+2+2+1+1=30

对于任意一个k>=1,每往前找到next[k]的位置,k与next[k]之间的字符串就是当前考虑的在找匹配的字符串,也就是说,每到一个k 能往前面找到多少次next[k]那么该字符串就是被匹配了多少次

#include<cstdio>
#include<iostream>
using namespace std;
char a[200010];
int nxt[200010];  
int main(){
	int n;
	scanf("%d",&n);
	while(n--){
		int m,sum=0;
		scanf("%d%s",&m,a);
		int i=-1,j=0;  
		nxt[0]=-1;  
    	        while(j<m){  
        	        if(i==-1||a[i]==a[j])nxt[++j]=++i;  
        	        else i=nxt[i];  
 		 } 
		for(i=1;i<=m;i++){
			j=i;
			sum++;
			while(nxt[j]!=0){
				sum=(sum+1)%10007;
				j=nxt[j];
			}	
		}
		printf("%d\n",sum);
	}
  return 0;	
} 



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值