POJ 3280 Cheapest Palindrome——动态规划

Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag’s contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is “abcba” would read the same no matter which direction the she walks, a cow with the ID “abcb” can potentially register as two different IDs (“abcb” and “bcba”).

FJ would like to change the cows’s ID tags so they read the same no matter which direction the cow walks by. For example, “abcb” can be changed by adding “a” at the end to form “abcba” so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters “bcb” to the begining to yield the ID “bcbabcb” or removing the letter “a” to yield the ID “bcb”. One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow’s ID tag and the cost of inserting or deleting each of the alphabet’s characters, find the minimum cost to change the ID tag so it satisfies FJ’s requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3…N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

Hint

If we insert an “a” on the end to get “abcba”, the cost would be 1000. If we delete the “a” on the beginning to get “bcb”, the cost would be 1100. If we insert “bcb” at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.

题目大意:

题目很长,但意思很简单,给你一串字符串,还有一些字母删除和增加的开销,问能使这个字符串成为回文字符串所需要的最小开销。

题目分析

  1. 对于经验不充分的来说(比如我),可能会想到贪心,每一步选最优的即可,但稍加思考,就知道是行不通的。因为你当前选择最优,并不代表全局最优,可能你当前开销大一些,但是总体来看开销要小得多。
  2. 那么我们就只能采用动态规划思想作,那么如何定义dp数组的含义呢?这是这道题的难点之一。
    我们令dp[i][j]表示字符串的第i个字符到第j个字符所能实现的最小开销。
  3. 这道题难点之二,就是要简化操作,对于每一个字符,删除和操作其实对于回文字符串的形成是一样的,不影响我们状态的转移过程,所以,我们只需要保存每一个字符删除和操作开销最小的一个即可。
  4. 那么如何状态转移呢?
    ①如果s[i]=s[j],那么此次操作不增加开销,所以dp[i][j]=dp[i+1][j-1]也就是从i+1字符到j-1字符所需要的开销,可能有人会问,那可能i+1>j-1,那没关系,只需要初始化dp数组为0,那么状态转移后开销仍然是0咯!
    ②如果不等呢?那么就需要增加或者删除i字符或者j字符,所以只需要比较dp[i+1][j]+alpha[s[i]-‘a’]和dp[i][j-1]+alpha[s[j]-‘a’]那个小即可,第一个表示的意思是删除或增加i字符,就等于从i+1字符到j字符的开销加上对于s[i]字符操作的开销;第二个表示删除或增加j字符开销,就等于从i到j-1字符的开销加上对于s[j]字符的开销,最后二者取最小值即可。

代码

#include<iostream>
#include<cstdio>
#include<string>
#include<limits.h>
#include<algorithm>
#include<cstring>
#include<math.h>
#include<set>
#include<vector>
#include<queue>
using namespace std;
typedef long long ll;
int dp[2010][2010];
int alpha[26];
int main() {
	string s;
	int n,m;
	char ch;
	while(scanf("%d%d",&n,&m)!=EOF) {
		cin>>s;
		int x,y;
		for(int i=0; i<n; i++) {
			getchar();
			cin>>ch;
			cin>>x>>y;
			alpha[ch-'a']=min(x,y);
		}
		memset(dp,0,sizeof(dp));
		for(int i=m-2;i>=0;i--){
			for(int j=i+1;j<m;j++){
				if(s[i]==s[j]){
					dp[i][j]=dp[i+1][j-1];
				}else{
					dp[i][j]=min(dp[i+1][j]+alpha[s[i]-'a'],dp[i][j-1]+alpha[s[j]-'a']);	
				}
			}
		}
		printf("%d\n",dp[0][m-1]);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值