POJ 3181 Dollar Dayz——两种方法实现划分数问题

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are:

    1 @ US$3 + 1 @ US$2

    1 @ US$3 + 2 @ US$1

    1 @ US$2 + 3 @ US$1

    2 @ US$2 + 1 @ US$1

    5 @ US$1

Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of 1.. 1.. 1..K (1 <= K <= 100).

Input

A single line with two space-separated integers: N and K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

Sample Input

5 3

Sample Output

5

题目大意:

问从1-k这k个整数,有多少种组合方法使得和为n?1-k这k个数可以无限使用

题目分析

  1. 典型的划分数问题,只需要套公式即可。dp[i][j]表示的是i划分成不超过j组的总数。比如4,可以划分成三组(1+1+2)、划分成两组(2+2,1+3),划分成1组(4),dp[4][3]就是说4划分不超过3组的数量
  2. 划分数问题的公式是dp[i][j]=dp[i-j][j]+dp[i][j-1],怎么理解呢?可以这么想,它的组合分成划分成j组和划分不超过j组两大类。
    ①化成j组,那先保证每一组不为零,所以每一组先放个1,所以i-j
    ②划分不超过j组,那么就是dp[i][j-1],把划分数-1就行啦
  3. 这道题坑在需要高精度表示结果,所以单纯的int 或者long long都无济于事,需要用一些小技巧。只需要将低18位保存在一个数组里,高18位保存在另一个数组里面,这样就可以满足题目要求了。

代码一(二维数组)

#include<iostream>
#include<cstdio>
#include<string>
#include<limits.h>
#include<algorithm>
#include<cstring>
#include<math.h>
#include<set>
#include<vector>
#include<queue>
using namespace std;
typedef long long ll;
__int64 a[1001][101],b[1001][101],inf;

int main() {
	inf=1e18;
	int n,k;
	while(scanf("%d%d",&n,&k)!=EOF) {
		memset(a,0,sizeof(a));//低位 
		memset(b,0,sizeof(b));//高位 
		for(int i=0;i<=k;i++){
			a[0][i]=1;
		}
		for(int i=1;i<=k;i++){
			for(int j=1;j<=n;j++){
				if(j-i>=0){
					b[j][i]=b[j-i][i]+b[j][i-1]+(a[j-i][i]+a[j][i-1])/inf;
					a[j][i]=(a[j-i][i]+a[j][i-1])%inf;
				}else{
					b[j][i]=b[j][i-1];
					a[j][i]=a[j][i-1];
				}
			}
		}
		if(b[n][k]>0){
			printf("%I64d",b[n][k]);
		}
		printf("%I64d\n",a[n][k]);
	}
	return 0;
}

代码二(一维数组)

#include<iostream>
#include<cstdio>
#include<string>
#include<limits.h>
#include<algorithm>
#include<cstring>
#include<math.h>
#include<set>
#include<vector>
#include<queue>
using namespace std;
typedef long long ll;
__int64 a[1001],b[1001],inf;

int main() {
	inf=1e18;
	int n,k;
	while(scanf("%d%d",&n,&k)!=EOF) {
		memset(a,0,sizeof(a));//低位 
		memset(b,0,sizeof(b));//高位 
		a[0]=1;
		for(int i=1; i<=k; i++) {
			for(int j=0; j<=n-i; j++) {
				if(a[j]>0||b[j]>0) {
					b[j+i]=b[j+i]+b[j]+(a[j+i]+a[j])/inf;
					a[j+i]=(a[j+i]+a[j])%inf;
				}
			}
		}
		if(b[n]>0){
			printf("%I64d",b[n]);
		}
		printf("%I64d\n",a[n]);
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值