poj 3259 Wormholes——弗洛伊德判断是否存在负环

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself 😃 .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2…M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2…M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1…F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

题目大意:

说的简单点吧,就是判断是否有负权环存在,输入f代表测试样例数目,输入n、m、w代表场地数目、边数目、负边数目;输入s、e、t代表起始点、终点、时间开销

题目解析

  1. 负权图问题的裸体,如果知道判断负环的算法,很简单,套就完事了。
  2. 能用于负权图的有bellman-ford算法和floyd算法,两个都很简单,这里我只介绍floyd算法把
  3. 按照floyd走一遍,然后判断cost【i】【i】如果存在负数,那么说明有负环存在。(cost【i】【i】初始值为0)
    注意!这里判断cost【i】【i】必须嵌套在floyd循环当中,否则超时(我tel了几次才知道)
  4. path是双向的,但是负边是单向的one-way,这个也要注意!

贴代码把,一看就懂。。。

#include<iostream>
#include<cstdio>
#include<string>
#include<limits.h>
#include<algorithm>
#include<cstring>
#include<math.h>
#include<set>
#include<vector>
#include<queue>
#include<set>
#include<stdlib.h>
#include<time.h>
using namespace std;
typedef long long ll;
#define inf	1000000
typedef pair<int,int>	P;
int cost[600][600];
int n,m,w;

void init() {
	fill_n(&cost[0][0],600*600,11000);
	for(int i=1; i<=n; i++) {
		cost[i][i]=0;
	}
}

bool solve() {
	for(int k=1; k<=n; k++) {
		for(int i=1; i<=n; i++) {
			for(int j=1; j<=n; j++) {
				if(cost[i][j]>cost[i][k]+cost[k][j]) {
					cost[i][j]=cost[i][k]+cost[k][j];
					if(cost[i][i]<0){
						return true;
					}
				}
			}
		}
	}
	return false;
}
int main() {
	int f;
	scanf("%d",&f);
	while(f--) {
		scanf("%d%d%d",&n,&m,&w);
		init();
		int a,b,c;
		for(int i=0; i<m; i++) {
			scanf("%d%d%d",&a,&b,&c);
			if(c<cost[a][b]) {
				cost[a][b]=cost[b][a]=c;
			}
		}
		for(int i=0; i<w; i++) {
			scanf("%d%d%d",&a,&b,&c);
			cost[a][b]=-c;
		}
		if(solve()) {
			printf("YES\n");
		} else {
			printf("NO\n");
		}
	}
	return 0;
}
  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值