Series 1 hdu4927


Series 1

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 238    Accepted Submission(s): 76


Problem Description
Let A be an integral series {A 1, A 2, . . . , A n}.

The zero-order series of A is A itself.

The first-order series of A is {B 1, B 2, . . . , B n-1},where B i = A i+1 - A i.

The ith-order series of A is the first-order series of its (i - 1)th-order series (2<=i<=n - 1).

Obviously, the (n - 1)th-order series of A is a single integer. Given A, figure out that integer.
 

Input
The input consists of several test cases. The first line of input gives the number of test cases T (T<=10).

For each test case:
The first line contains a single integer n(1<=n<=3000), which denotes the length of series A.
The second line consists of n integers, describing A 1, A 2, . . . , A n. (0<=A i<=10 5)
 

Output
For each test case, output the required integer in a line.
 

Sample Input
   
   
2 3 1 2 3 4 1 5 7 2
 

Sample Output
   
   
0 -5



多校联合的第6场
题意:就把一个序列的后一项减前一项,直到最后得到的数。数据有点大

开始看上去很简单的问题。wa了很久,tle了很久
本题用大数问题。用java课轻松搞定。但不明白为什么O(n)的复杂度过不了。据说要姿势优美一点,哎。卧槽,换了各种姿势。各种各样的TLE由O(n^2)的复杂度变到O(n)。哎,主要打杨辉三角,注意不能用传统的,用组合数的性质。这样预处理一下就OK
上java代码:


import java.util.*;
import java.math.*;

public class Main{
	
	public static void main(String[] args) {  
	   
		BigInteger b[]=new BigInteger [3005]; 
	    b[1]=BigInteger.valueOf(1);
	    b[0]=BigInteger.valueOf(1);
		Scanner cin=new Scanner(System.in);
		int t;
		int n;	
		BigInteger a[]=new BigInteger[3005];
		BigInteger  m;
		t=cin.nextInt();
		for(int tt=0;tt<t;tt++){	
			n=cin.nextInt();
			
			for(int ii=1;ii<n;ii++){
		    	BigInteger ttt=BigInteger.valueOf(ii);
		    	b[ii]=b[ii-1].multiply(BigInteger.valueOf(n-ii)).divide(ttt);
		    }
			
			for(int j=0; j<n; j++) {
				a[j]=cin.nextBigInteger();
	        }
			BigInteger ans=BigInteger.valueOf(0);
			BigInteger aa;
	        for(int k=n-1,ii=1; k>=0; k--,ii++) {
	            if(ii%2==1) ans=ans.add(a[k].multiply(b[k]));
	            else ans=ans.subtract(a[k].multiply(b[k]));
	        }
			System.out.println(ans);
		}
	}
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值