天数计算

【题目描述】图图学习了计算每月有多少天,以及判断平年和闰年的方法,现在他想用编程来实现。应该如何实现呢?
【输入】输入一行,包含两个整数,分别表示年份和月份。
【输出】输出一行,包含一个整数,表示输入的这个月份对应的天数。
【输入样例1】2023 2
【输出样例1】28
【输入样例2】2024 1
【输出样例2】31

#include <iostream>
using namespace std;
bool is_leap_year(int year) {
    return (year % 4 == 0 && year % 100 != 0) || (year % 400 == 0);
}

int get_days(int year, int month) {
    int days_in_month[] = {31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31};
    if (is_leap_year(year)) {
        days_in_month[1] = 29;
    }
    return days_in_month[month - 1];
}

int main() {
    int year, month;
    cin >> year >> month;
    cout << get_days(year, month) <<endl;
    return 0;
}

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值