1147 Heaps (30 point(s))
In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))
Your job is to tell if a given complete binary tree is a heap.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.
Output Specification:
For each given tree, print in a line Max Heap
if it is a max heap, or Min Heap
for a min heap, or Not Heap
if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.
Sample Input:
3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
Sample Output:
Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
题目大意:给一个序列,先做判断是大顶堆,小顶堆还是两者都不是,然后给出后序遍历。
解题思路:自己去实现大小堆判断太费事了,stl有现成的heap模板,就很简单的用make_heap函数然后判断之后的数组和之前的是不是一样就行了,如果不是大也不是小,那就输出Not Heap,然后后续遍历的问题其实就是先左子树后右子树,然后根节点,对于数组表示的堆结构,对于下标为i的元素,他的左子树为2*i,右子树为2*i+1,就简单的写个递归。
代码如下:
#include<iostream>
#include<string.h>
#include<vector>
#include<algorithm>
#include<iomanip>
#include<time.h>
#include<math.h>
#include<set>
#include<list>
#include<climits>
#include<queue>
#include<cstring>
#include<map>
#include<stack>
#include<string>
using namespace std;
bool cmp(int a, int b) {
return a > b;
}
vector<int> r;
void Postorder(int i,int k,vector<int> a)
{
if (i <=k)
{
Postorder(i * 2,k,a);
Postorder(i * 2 + 1,k,a);
r.push_back(a[i-1]);
}
}
int main()
{
int N,T;
scanf("%d %d", &T, &N);
while (T--) {
vector<int> res;
for (int i = 0; i < N; i++) {
int tmp;
scanf("%d", &tmp);
res.push_back(tmp);
}
Postorder(1, N, res);
vector<int> tmp = res;
vector<int> typ = res;
make_heap(tmp.begin(), tmp.end());
make_heap(typ.begin(), typ.end(), cmp);
if (tmp == res) {
printf("Max Heap\n");
for (int i = 0; i < r.size(); i++) {
if (i != r.size() - 1) {
printf("%d ", r[i]);
}
else {
printf("%d\n", r[i]);
}
}
}
else if(typ==res){
printf("Min Heap\n");
for (int i = 0; i < r.size(); i++) {
if (i != r.size() - 1) {
printf("%d ", r[i]);
}
else {
printf("%d\n", r[i]);
}
}
}
else {
printf("Not Heap\n");
for (int i = 0; i < r.size(); i++) {
if (i != r.size() - 1) {
printf("%d ", r[i]);
}
else {
printf("%d\n", r[i]);
}
}
}
r.clear();
}
return 0;
}