NOJ1098Rails——出栈顺序

74 篇文章 0 订阅

Rails

时间限制(普通/Java):1000MS/3000MS          运行内存限制:65536KByte
总提交:370            测试通过:111

描述

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track. 

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has coaches numbered in increasing order . The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be . Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

输入

The input file consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of The last line of the block contains just 0. 
The last block consists of just one line containing 0. 

输出

The output file contains the lines corresponding to the lines with permutations in the input file. A line of the output file contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input file. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input file. There is no line in the output file corresponding to the last ``null'' block of the input file.

样例输入

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

样例输出

Yes
No

Yes

题目来源

Central European Regional 1997


分析:C++数据结构中很重要的题目。这里亲自写,感受不同了~

考验出栈顺序是否可行。自己写数组较快。内部判断条件。注意 j 的限制条件必须加上,因为 i 会变小。

//Rails——出栈顺序
#include<stdio.h>

int main()
{
	int a[1000], input[1000];
	int n;
	while(scanf("%d",&n) && n != 0)
	{
		while(scanf("%d",&input[0]) && input[0]) // 0
		{
			for(int i=1;i<n;i++) scanf("%d",&input[i]);
			int num = 0; // input匹配个数
			for(int i=0,j=1;i<n&&j<=n;i++,j++) // j<=n!!!因为i减小了,必须加上j的限制条件
			{
				a[i] = j;
				while(a[i] == input[num])
				{
					num++;
					i--;
					if(i == -1) break;
				}
			}
			if(num == n) printf("Yes\n");
			else printf("No\n");
		}
		printf("\n");
	}

	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值