POJ2533——Longest Ordered Subsequence

Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 32548 Accepted: 14219

Description

A numeric sequence of  ai is ordered if  a1 <  a2 < ... <  aN. Let the subsequence of the given numeric sequence ( a1a2, ...,  aN) be any sequence ( ai1ai2, ...,  aiK), where 1 <=  i1 <  i2 < ... <  iK <=  N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion


分析:DP。O(n*n)比较简单。注意初始化。
当然还有一种O(nlogn)的方法。
//独立成功!——还是有问题啊 = =
//dp[i]表示最后一个为a[i]的最长上升序列的长度
//可以用二分法优化至O(nlogn)
#include<iostream>
using namespace std;

int dp[1001] = {0};

int main()
{
	int a[1001], n;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&a[i]);
		dp[i] = 1; // !!!
	}

	for(int i=1;i<n;i++)
	{
		for(int j=0;j<i;j++)
		{
			if(a[j] < a[i])
				dp[i] = max(dp[i], dp[j] + 1);
		}
	}
	int ans = -1;
	for(int i=0;i<n;i++)
		if(ans < dp[i])
			ans = dp[i];

	printf("%d\n",ans);

	return 0;
}

O(nlogn) 运用二分法。
//独立成功!——还是有问题啊 = =
//dp[i]表示最后一个为a[i]的最长上升序列的长度
//可以用二分法优化至O(nlogn)
#include<iostream>
using namespace std;

const int INF = 10001;

//二分查找,返回下表,若不存在,返回s[]中比key小的最大那个数的下标+1
int bin_search(int s[], int key, int len)
{
	int left = 0, right = len, mid;
	while(left != right)
	{
		mid = (left+right) / 2;
		if(key == s[mid])
			return mid;
		else if(s[mid] < key)
			left = mid+1;
		else
			right = mid;
	}
	return left;
}

int main()
{
	int a[1001], n, s[1001];
	scanf("%d",&n);
	for(int i=0;i<n;i++)
		scanf("%d",&a[i]);
	//dp[]的每一个取值k,s[k]代表dp[i]=k的所有a[i]中的最小值,即s[k]=min{a[i]}
	s[0] = -1; // 下界无穷小
	int len = 1; // s[]的长度
	
	for(int i=0;i<n;i++)
	{
		s[len] = INF; // 上界无穷大,指针len指向s[]的最后一个元素的下一位
		int j = bin_search(s, a[i], len);
		if(j == len) // a[i]大于s最大(最后)的元素
			len++;
		s[j] = a[i];
	}
	printf("%d\n",len-1);
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值