U - Burning Bridges (求桥 + 判重边)

U - Burning Bridges

 

Ferry Kingdom is a nice little country located on N islands that are connected by M bridges. All bridges are very beautiful and are loved by everyone in the kingdom. Of course, the system of bridges is designed in such a way that one can get from any island to any other one.

But recently the great sorrow has come to the kingdom. Ferry Kingdom was conquered by the armies of the great warrior Jordan and he has decided to burn all the bridges that connected the islands. This was a very cruel decision, but the wizards of Jordan have advised him no to do so, because after that his own armies would not be able to get from one island to another. So Jordan decided to burn as many bridges as possible so that is was still possible for his armies to get from any island to any other one.

Now the poor people of Ferry Kingdom wonder what bridges will be burned. Of course, they cannot learn that, because the list of bridges to be burned is kept in great secret. However, one old man said that you can help them to find the set of bridges that certainly will not be burned.

So they came to you and asked for help. Can you do that?

 

Input

 

The input contains multiple test cases. The first line of the input is a single integer T (1 <= T <= 20) which is the number of test cases. T test cases follow, each preceded by a single blank line.

The first line of each case contains N and M - the number of islands and bridges in Ferry Kingdom respectively (2 <= N <= 10 000, 1 <= M <= 100 000). Next M lines contain two different integer numbers each and describe bridges. Note that there can be several bridges between a pair of islands.

 

Output

 

On the first line of each case print K - the number of bridges that will certainly not be burned. On the second line print K integers - the numbers of these bridges. Bridges are numbered starting from one, as they are given in the input.

Two consecutive cases should be separated by a single blank line. No blank line should be produced after the last test case.

 

Sample Input

 

2

6 7
1 2
2 3
2 4
5 4
1 3
4 5
3 6

10 16
2 6
3 7
6 5
5 9
5 4
1 2
9 8
6 4
2 10
3 8
7 9
1 4
2 4
10 5
1 6
6 10

 

Sample Output

 

2
3 7

1
4 

 

思路:

求桥 + 判重边

AC历程:

Segmentation Fault,第一次遇到,很神奇!   就是:所谓的段错误就是指访问的内存超出了系统所给这个程序的内存空间

然后改大了数组,过了

还有就是:Segmentation Fault 试图把一个整数按照字符串的方式输出, 其它的自行百度。。。

代码:

 

#include<queue>   //割桥
#include<stack>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1e4+7;
#define mem(a,b) memset(a,b,sizeof(a))
//stack<int>st;
//low[]i及i的子孙相连的辈分最高的祖先节点所在的深度
//dfn[]i的深度
//tot树深,T_cou连通分量的个数
//in_stack[]是否在栈中
int dfn[maxn],low[maxn];
int tot,n,T_bridge;
int fi[maxn],len;
struct Adjacent
{
    int node;  //这条边的编号
    int U,V,ne;
    int cou,vis;  //cou计边的出现次数,vis记是否是桥
} Adj[20*maxn];
void add(int u,int v,int num)
{
    Adj[len].node=num;
    Adj[len].U=u;
    Adj[len].V=v;
    Adj[len].cou=Adj[len].vis=0;  //初始化
    Adj[len].ne=fi[u];
    fi[u]=len++;
     
    Adj[len].node=num;  //反向边
    Adj[len].U=v;
    Adj[len].V=u;
    Adj[len].cou=Adj[len].vis=0;
    Adj[len].ne=fi[v];
    fi[v]=len++;
}
void init()
{
    mem(low,0);
    mem(dfn,0);
    T_bridge=tot=0;
    mem(fi,-1);
    len=0;
}
void tarjan(int x,int y)
{
    dfn[x]=low[x]=++tot;
    for(int i=fi[x]; i!=-1; i=Adj[i].ne)
    {
        int v=Adj[i].V;
        if(!dfn[v])
        {
            tarjan(v,x);
            low[x]=min(low[x],low[v]);
            if(low[v]>dfn[x]&&Adj[i].cou==0)
            {
                T_bridge++;
                Adj[i].vis=1;
                Adj[i^1].vis=1;
            }
        }
        else if(v!=y)
            low[x]=min(low[x],dfn[v]);
    }
}
int main()
{
    int ca,m,cas=1;
    scanf("%d",&ca);
    while(ca--)
    {
        init();
        if(cas!=1)
            puts("");
        cas=0;
        scanf("%d %d",&n,&m);
        for(int i=1; i<=m; i++)
        {
            int u,v,flag=1;
            scanf("%d %d",&u,&v);
            for(int j=fi[u]; j!=-1; j=Adj[j].ne) //去重边
            {
                if(Adj[j].U==u&&Adj[j].V==v)
                {
                    flag=0;
                    Adj[j].cou++;
                    Adj[j^1].cou++;
                    break;
                }
            }
            if(flag)
                add(u,v,i);
        }
        for(int i=1; i<=n; i++)
            if(!dfn[i])
                tarjan(1,1);  //tarjan(i,i);
        printf("%d\n",T_bridge);
        int f=0;
        for(int i=0;i<len;i+=2)
        {
            if(Adj[i].vis)
            {
                if(f==0)
                    printf("%d",Adj[i].node);
                else
                    printf(" %d",Adj[i].node);
                f=1;
            }
        }
        if(T_bridge)   //为0不用再换行
            printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值