HDU - 4738 Caocao's Bridges(targan 求桥(割边) +判重边)

HDU - 4738 Caocao’s Bridges(targan 求桥 +判重边)

Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn’t give up. Caocao’s army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao’s army could easily attack Zhou Yu’s troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao’s army could be deployed very conveniently among those islands. Zhou Yu couldn’t stand with that, so he wanted to destroy some Caocao’s bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn’t be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.
Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.
Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn’t succeed any way, print -1 instead.
Sample Input
3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0
Sample Output
-1
4

题目大意:

有n个船,船之间通过桥相连,每个桥上都有一定的卫兵守护。
要破坏其中一个桥,让这n个船不连通,破坏的需要的卫兵数量就是守护这个桥卫兵的数量。
问:最少代价是多少。

抽象一下就是 n个点,m条边(有重边)的无向图,每个边都有一个权值。破坏一条边使图不连通,并使代价最小。
也就是找一个权值最小的 (割边)
找不到 输出-1

解题思路:

用targan求割边即可。

坑点:
1.如果求出来的最小割边为0,也就是这个桥没士兵守护时,我们也需要派一个士兵去破坏
如果不连通,那直接输出0,如果找不到割边 直接输出-1.
2.有重边。解决重边问题,可以给每个边都加个id,然后在targan中,找边的时候只要不等于上一条的id就可以走。

AC代码:

#include <bits/stdc++.h>
#define ll long long
#define INF 0xfffffff
using namespace std;
const int maxn = 1e3+100;
const int maxm = 1e6+100;
int DFN[maxn];
int LOW[maxn];
int timing;
int head[maxn];
int cnt = 0;
int ans ;
int n,m;
struct node{
	int to;
	int w;
	int id;
	int next;
}side[maxm];
void init(){
	memset(head,-1,sizeof(head));
	memset(DFN,0,sizeof(DFN));
	memset(LOW,0,sizeof(LOW));
	ans =INF;
	cnt = 0;
	timing = 0;
}
void add(int x,int y,int w,int id){
	side[cnt].to = y;
	side[cnt].w = w;
	side[cnt].id = id;
	side[cnt].next =head[x];
	head[x] = cnt++;
}
void targan(int u,int fid ){
	timing++;
	DFN[u] = LOW[u] = timing;
	for(int i=head[u];i!=-1;i=side[i].next){
		int v = side[i].to;
		if(fid == side[i].id){
			continue;
		}
		int w = side[i].w;
		if(!DFN[v]){
			targan(v,side[i].id);
			LOW[u] = min(LOW[u],LOW[v]);
			if(LOW[v]>DFN[u]){//是桥
				ans = min(ans,w);
			}
		}else{
			LOW[u] = min(LOW[u],DFN[v]);
		}
	}
}
int main(){
	std::ios::sync_with_stdio(0);
	while(cin>>n>>m){
	
		if(n==0&&m==0) break;
		init();
		int x,y,w;
		for(int i=1;i<=m;i++){
			cin>>x>>y>>w;
			add(x,y,w,i);
			add(y,x,w,i);
		}
		int num = 0;
		for(int i=1;i<=n;i++){
			if(DFN[i]==0){
				targan(i,-1);
				num++;
			}
		}
		if(num>1){//之前的图不连通 
			cout<<"0"<<endl;
			continue;
		}
		if(ans == INF) cout<<"-1"<<endl;
		else if(ans ==0) cout<<"1"<<endl;
		else cout<<ans<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值