hdu4734(数位DP)

地址:http://acm.hdu.edu.cn/showproblem.php?pid=4734

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1095    Accepted Submission(s): 443


Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 

Sample Input
  
  
3 0 100 1 10 5 100
 

Sample Output
  
  
Case #1: 1 Case #2: 2 Case #3: 13
 

水题,注意一下时间就行了。

代码:

#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
#define LL __int64
#define Max 200010
int num[15],dp[15][4700],top;
int dfs(int len,int n,bool p){
    if(n<0) return 0;
    if(!len) return n>=0;
    if(!p&&~dp[len][n]) return dp[len][n];
    int u=p?num[len]:9;
    int ans=0,k=1<<(len-1);
    for(int i=0;i<=u;i++)
        ans+=dfs(len-1,n-i*k,i==u&p);
    if(!p) dp[len][n]=ans;
    return ans;
}
int getans(int l,int r){
    top=0;
    for(int i=1;l;i*=2,l/=10)
        top+=((l%10)*i);
    int len=0;
    for(;r;r/=10)
        num[++len]=r%10;
    return dfs(len,top,1);
}
int main(){
    int t,cas=1;
    memset(dp,-1,sizeof(dp));
    scanf("%d",&t);
    while(t--){
        int l,r;
        scanf("%d%d",&l,&r);
        printf("Case #%d: %d\n",cas++,getans(l,r));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值