DP poj1745 Divisibility

题目地址链接:http://poj.org/problem?id=1745

题目:


Divisibility

Description

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

You are to write a program that will determine divisibility of sequence of integers. 

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible

Source

解题报告:

这个题用了动态规划的思想,只有两个状态,即:加一个数之前的状态和加一个数之后的状态,即代码中的x[]状态和y[]状态,我的代码虽然有点罗嗦,但是对于看代码的人来说容易理解一点,注意17行的状态书写形式,主要是为了防止出现下标为负数的情况,而x状态与y状态的传递则是这个题的中心思想,再说一下x代表的状态的具体意思(y同),即:x[i]的下标i为上一个状态与a的和或者差的余数,而x[i]则记录了这个余数所代表的状态的情况,1就是存在,0则为不存在,而最后只需查看余数为0的状态情况就行了,要是为0,则不能满足条件,1则是满足条件,根据情况输出不同的语句。

代码:

#include<stdio.h>
#include<string.h>
int x[205],y[205];
int a[10005];
int main()
{
	int i,j,k,n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=1;i<=n;i++)scanf("%d",&a[i]);
		memset(y,0,sizeof(y));
		int flag=1;
		for(i=1;i<=n;i++)
		{
			if(flag)
			{
				y[(m+a[1]%m)%m]=1;
				flag=0;
				memcpy(x,y,sizeof(y));
				continue;
			}
			memset(y,0,sizeof(y));
			for(j=0;j<m;j++)
			{
				if(x[j]==1)
				{
					y[(m+j+a[i]%m)%m]=1;
					y[(m+j-a[i]%m)%m]=1;
				}
			}
			memcpy(x,y,sizeof(y));
		}
		if(x[0]==1)
			printf("Divisible\n");
		else
			printf("Not divisible\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值