Kindergarten Counting Game
Kindergarten Counting Game |
Everybody sit down in a circle. Ok. Listen to me carefully.
``Woooooo, you scwewy wabbit!''
Now, could someone tell me how many words I just said?
Input and Output
Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).
Your program should output a word count for each line of input. Each word count should be printed on a separate line.
Sample Input
Meep Meep! I tot I taw a putty tat. I did! I did! I did taw a putty tat. Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...
Sample Output
2 7 10 9
这题没什么好说的,基础题,只要注意单词与其他字符之间加一个判断变量就是不难得到结果。
code:
#include<iostream>
#include<string>
using namespace std;
int main()
{
int n,i;
bool f1,f2;
string s;
while(getline(cin,s))
{
n=0;
f1=f2=false;
for(i=0;s[i]!='\0';i++)
{
if((s[i]>='a'&&s[i]<='z')||(s[i]>='A'&&s[i]<='Z'))f1=true;
else
{
f2=true;
if(f1)n++;
f1=f2=false;
}
}
cout<<n<<endl;
}
return 0;
}