hdu 1021 Fibonacci Again(矩阵连乘 || 循环节)

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1021

Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2). 
 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000). 
 

Output

Print the word "yes" if 3 divide evenly into F(n). 

Print the word "no" if not. 
 

Sample Input

    
    
0 1 2 3 4 5
 

Sample Output

    
    
no no yes no no no
矩阵连乘:

#include <iostream>
#include <cstdio>
using namespace std;
struct matrie{
    int m[2][2];
};
matrie A={  // f[n],f[n-1] ~ f[1],f[0] ~ pow=n-1
    1,1,
    1,0
};
matrie I={
    1,0,
    0,1
};
matrie multi(matrie a,matrie b){
    matrie c;
    for(int i=0;i<2;i++){
        for(int j=0;j<2;j++){
            c.m[i][j]=0;
            for(int k=0;k<2;k++){
                c.m[i][j]+=(a.m[i][k]*b.m[k][j])%3;
            }
            c.m[i][j]%=3;
        }
    }
    return c;
}
matrie power(int p){
    matrie ans=I,tmp=A;  // 矩阵结构体可以直接相等
    while(p){
       if(p&1) ans=multi(ans,tmp);
       tmp=multi(tmp,tmp);
       p>>=1;
    }
    return ans;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    int n;
    while(cin>>n){
        if(n==0){
             puts("no");
             continue;
        }
        matrie w=power(n-1);
        int ans=(w.m[0][0]*7+w.m[0][1]*11)%3;
        if(ans==0)puts("yes");
        else puts("no");
    }
    return 0;
}
循环节:
#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
LL f[100];
int main()
{
    /*f[0]=7;
    f[1]=11;
    for(int i=2;i<40;i++){
        f[i]=(f[i-1]+f[i-2])%3;
        cout<<f[i]<<" ";
    }*/
    int n;
    while(cin>>n){
         if((n-2)%4==0)printf("yes\n");
         else puts("no");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值