hdu 1217 Arbitrage(floyd 每对顶点间的“最短距离”)

题目:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=22312

Time Limit: 1000MS Memory Limit: 32768KB 64bit IO Format: %I64d & %I64u

 Status

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent. 

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 
 

Input

The input file will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible. 
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n. 
 

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No". 
 

Sample Input

    
    
3 USDollar BritishPound FrenchFranc 3 USDollar 0.5 BritishPound BritishPound 10.0 FrenchFranc FrenchFranc 0.21 USDollar 3 USDollar BritishPound FrenchFranc 6 USDollar 0.5 BritishPound USDollar 4.9 FrenchFranc BritishPound 10.0 FrenchFranc BritishPound 1.99 USDollar FrenchFranc 0.09 BritishPound FrenchFranc 0.19 USDollar 0
 

Sample Output

    
    
Case 1: Yes Case 2: No
 
有向图,把A-->B的汇率作为两点间的权值,如果想要获利那么就需要:dis[i][k]*dis[k][j]>1/dis[j][i] 是不是?进一步写成dis[i][k]*dis[k][j]>dis[i][j] 尽量避免浮点数的除法运算。于是可以用floyd更新每一对点的汇率,也就是更新dis[i][j]。最后如果有一对i,j满足:dis[i][j]*dis[j][i]>1那么就获利了。
#include <iostream>
#include <cstdio>
#include <cstring> //0xc0000094 除以0了
#include <string>
#include <map>
using namespace std;
const int N=35;
int n,m;
double mymap[N][N],dis[N][N];
int pre[N][N];
void floyd(){
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            dis[i][j]=mymap[i][j];
        }
    }
    for(int k=1;k<=n;k++){
        for(int i=1;i<=n;i++){
            for(int j=1;j<=n;j++){
                if(dis[i][k]*dis[k][j]>dis[i][j]){  
                     dis[i][j]=dis[i][k]*dis[k][j];
                }
            }
        }
    }
}
int main()
{
    //freopen("cin.txt","r",stdin);
    int ca=1;
    while(cin>>n&&n){
        memset(mymap,0,sizeof(mymap));
        map<string,int> mp;
        string str;
        for(int i=1;i<=n;i++){
            cin>>str;
            mp[str]=i;
        }
        scanf("%d",&m);
        string s1,s2;
        double y;
        while(m--){
            cin>>s1>>y>>s2;
            int a=mp[s1],b=mp[s2];
            mymap[a][b]=y;   
        }
        floyd();
        for(int i=1;i<=n;i++){
           for(int j=1;j<=n;j++){
                if(dis[i][j]*dis[j][i]-1>1e-6){
                     printf("Case %d: Yes\n",ca++);
                     goto loop;
                }
           }
        }
        printf("Case %d: No\n",ca++);
loop:;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值