zoj 3640 Help Me Escape(概率DP)

题目:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3640

Help Me Escape

Time Limit: 2 Seconds       Memory Limit: 32768 KB

Background

    If thou doest well, shalt thou not be accepted? and if thou doest not well, sin lieth at the door. And unto thee shall be his desire, and thou shalt rule over him. 
    And Cain talked with Abel his brother: and it came to pass, when they were in the field, that Cain rose up against Abel his brother, and slew him. 
    And the LORD said unto Cain, Where is Abel thy brother? And he said, I know not: Am I my brother's keeper? 
    And he said, What hast thou done? the voice of thy brother's blood crieth unto me from the ground. 
    And now art thou cursed from the earth, which hath opened her mouth to receive thy brother's blood from thy hand; 
    When thou tillest the ground, it shall not henceforth yield unto thee her strength; a fugitive and a vagabond shalt thou be in the earth.

—— Bible Chapter 4

Now Cain is unexpectedly trapped in a cave with N paths. Due to LORD's punishment, all the paths are zigzag and dangerous. The difficulty of the ith path is ci.

Then we define f as the fighting capacity of Cain. Every day, Cain will be sent to one of the N paths randomly.

Suppose Cain is in front of the ith path. He can successfully take ti days to escape from the cave as long as his fighting capacity f is larger than ci. Otherwise, he has to keep trying day after day. However, if Cain failed to escape, his fighting capacity would increase ci as the result of actual combat. (A kindly reminder: Cain will never died.)

As for ti, we can easily draw a conclusion that ti is closely related to ci. Let's use the following function to describe their relationship:

After D days, Cain finally escapes from the cave. Please output the expectation of D.

Input

The input consists of several cases. In each case, two positive integers N and f (n ≤ 100, f ≤ 10000) are given in the first line. The second line includes N positive integers ci (ci ≤ 10000, 1 ≤ i ≤ N)

Output

For each case, you should output the expectation(3 digits after the decimal point).

Sample Input
3 1
1 2 3
Sample Output
6.889
分析:又学了一种DP,概率型动态规划。本题题意:cain被困在洞穴中,他有一定的战斗值f,有多条逃脱的道路,如果战斗值f比道路的危险指数ci高的话,他就可以在ti天后出去,如果小于等于则需要第二天f=f+ci时再一次比较。求出相应的逃脱期望。状态转移:如果f>max{ci},那么天数的期望就为dp[f]=1/n*Σti,否则,dp[f]=1/n*Σti(f>ci)+1/n*Σ(1+dp[f+ci])。传统的DP用数组来进行转移即可,但这里因为数组下标存在越界,不存在已计算的对应dp[dex+ci]等问题,所以单独写一个递归函数。
对了,现在才发现对于double,memset也好用。
#include <iostream> 
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int maxn=1e4+10;
int n,f;
double dp[maxn],p;
bool flag[maxn];
int t[105],c[105],cmax;
double cal(int x){  //因为数组下标存在越界,不存在已计算的对应dp[dex+ci]等问题,所以单独写一个递归函数
    if(x>cmax){
        double res=0;
        for(int i=1;i<=n;i++) res+=p*t[i];
        return res;
    }
    if(flag[x]) return dp[x];
    for(int i=1;i<=n;i++){
        if(x>c[i]) dp[x]+=p*t[i];
        else dp[x]+=p*(1+cal(x+c[i]));
    }
    flag[x]=1;
    return dp[x];
}
int main()
{
    //freopen("cin.txt","r",stdin);
    double qw=(1+sqrt(5.0))/2;
    while(cin>>n>>f){
        memset(dp,0,sizeof(dp));
        memset(flag,0,sizeof(flag));
        cmax=-1;
        p=1.0/n;
        for(int i=1;i<=n;i++){
            scanf("%d",&c[i]);
            t[i]=(int)(qw*c[i]*c[i]);
            cmax=max(cmax,c[i]);
        }
        double ans=cal(f);
        printf("%.3lf\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值