hdu 1237 简单计算器(数组模拟栈,队列)

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1237

简单计算器

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15248    Accepted Submission(s): 5209


Problem Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
 

Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
 

Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
 

Sample Input
  
  
1 + 2 4 + 2 * 5 - 7 / 11 0
 

Sample Output
  
  
3.00 13.36
分析:四则运算里*,/的优先级高于+,-.我用符号栈(数组)和数字栈(数组)把所有的*,/都消灭掉,优先计算乘除运算,最后的符号数组和数字数组只涉及到加减运算,用队列来模拟从左到右的计算过程。
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char sta1[300];
double sta2[300];
char str[10010];
int t1,t2,w1,w2;
int main()
{
    //freopen("cin.txt","r",stdin);
    while(gets(str)&&strcmp(str,"0")){
        int i,length=strlen(str);
        t1=t2=w1=w2=0;
        double number=0,q1,q2;
        char ch;
        for(i=0;i<length;i++){
            if(str[i]==' ')continue;
            if(str[i]<='9'&&str[i]>='0'){
                number=number*10+str[i]-'0';
            }
            else {
                sta2[w2++]=number;
                number=0;
                if(t1!=t2&&(sta1[t2-1]=='/'||sta1[t2-1]=='*')){
                    ch=sta1[--t2];
                    q1=sta2[--w2];
                    q2=sta2[--w2];
                    if(ch=='*') sta2[w2++]=q1*q2;
                    else if(ch=='/') sta2[w2++]=q2/q1;
                }
                sta1[t2++]=str[i];
            }
        }
        sta2[w2++]=number;
        if(t2>0)ch=sta1[t2-1];
        if(t2>0&&(ch=='*'||ch=='/')){
             t2--;
             q1=sta2[--w2];
             q2=sta2[--w2];
             if(ch=='*') sta2[w2++]=q1*q2;
             else sta2[w2++]=q2/q1;
        }
        while(t1!=t2){
            ch=sta1[t1++];
            q1=sta2[w1++];  //sta2.pop();
            q2=sta2[w1++];  //sta2.pop();
            if(ch=='/')  number=q1/q2;
            else if(ch=='*') number=q1*q2;
            else if(ch=='+') number=q1+q2;
            else number=q1-q2;
            sta2[--w1]=number;
        }
        printf("%.2lf\n",sta2[w1++]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值