poj 1722 SUBTRACT(经典dp)

题目:http://poj.org/problem?id=1722

SUBTRACT
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 1696 Accepted: 746 Special Judge

Description

We are given a sequence of N positive integers a = [a1, a2, ..., aN] on which we can perform contraction operations.
One contraction operation consists of replacing adjacent elements ai and ai+1 by their difference ai-a i+1. For a sequence of N integers, we can perform exactly N-1 different contraction operations, each of which results in a new (N-1) element sequence.

Precisely, let con(a,i) denote the (N-1) element sequence obtained from [a1, a2, ..., aN] by replacing the elements ai and a i+1 by a single integer ai-a i+1 :

con(a,i) = [a1, ..., ai-1, ai-ai+1, ai+2, ..., aN]
Applying N-1 contractions to any given sequence of N integers obviously yields a single integer.
For example, applying contractions 2, 3, 2 and 1 in that order to the sequence [12,10,4,3,5] yields 4, since :
con([12,10,4,3,5],2) = [12,6,3,5]

con([12,6,3,5]   ,3) = [12,6,-2]

con([12,6,-2]    ,2) = [12,8]

con([12,8]       ,1) = [4]

Given a sequence a1, a2, ..., aN and a target number T, the problem is to find a sequence of N-1 contractions that applied to the original sequence yields T.

Input

The first line of the input contains two integers separated by blank character : the integer N, 1 <= N <= 100, the number of integers in the original sequence, and the target integer T, -10000 <= T <= 10000.
The following N lines contain the starting sequence : for each i, 1 <= i <= N, the (i+1) st line of the input file contains integer ai, 1 <= ai <= 100.

Output

Output should contain N-1 lines, describing a sequence of contractions that transforms the original sequence into a single element sequence containing only number T. The ith line of the output file should contain a single integer denoting the i th contraction to be applied.
You can assume that at least one such sequence of contractions will exist for a given input.

Sample Input

5 4
12
10
4
3
5

Sample Output

2
3
2
1
分析:很经典的dp题,开始真心想不出(甚至还往枚举搜索上想过||-_-,原来这是dp,现在发现动态规划在时间和空间上的好处真是巨大而明显)。
仿造的山寨代码:
/*
不断的作差,改变差顺序可以使得整个序列得到t。由于顺序的改变可能使得'-'变成'+',
比如12-(10-4-(3-5))=12-(10-4-3)-5=12-10+4+3-5.
于是问题就变成了n个数字的加减组合得到t。即a[1]-a[2]±a[3]±a[4]±...±a[n]=t.
进一步转化:±a[3]±a[4]±...±a[n]=t-a[1]+a[2]. 背包问题!--》
2a[3]+2[4]+...+2a[n]=t-a[1]+a[2]+(a[3]+[4]+...+a[n]);  2a[i]可选可不选,不选对应减
*/
#include <cstdio>
#include <cstring>
#include <cstring>
#define V 30000
#define N 200

int number[N];
int dp[V];
int record[N][V];
bool tag[N];
int sta[N];

int main() {
    //freopen("cin.txt","r",stdin);
    int n,t;
    while (~scanf("%d%d", &n, &t)) {
        int a, b;
        if (n == 1) {
            scanf("%d", &a);
            continue;
        }
        if (n == 2) {
            scanf("%d%d", &a, &b);
            printf("%d\n", 1);
            continue;
        }
        scanf("%d%d", &a, &b);
        int sum = 0;
        for (int i = 0; i < n-2; i++) {
            scanf("%d", &number[i]);
            sum += number[i];
            number[i] *= 2;
        }
        int v = sum-a+b+t;
        memset(dp,0,sizeof(dp));
        for (int i = 0; i < n-2;i++) {  //物件数
            for (int j = v; j - number[i] >= 0; j--) {
                if (dp[j] > dp[j-number[i]]+number[i]) record[i][j] = 0;  //不取 对应着‘-’
                else {
                    dp[j] = dp[j-number[i]]+number[i];
                    record[i][j] = 1;  //取 ‘+’
                }
            }
        }
        //printf("dp = %d(v= %d)\n", dp[v], v);
        int nowv = v;
        for (int i = n-2-1; i >= 0; i--) {
            if (record[i][nowv] == 1) {
                tag[i] = 1;
                nowv -= number[i];  //等式两边减去加上的数字
            }
            else tag[i] = 0;
        }

        int top = 0;
        for (int i = 0; i < n-2; i++) {
            if (tag[i] == 1) sta[top++] = i+2;  //dex
        }
        for (int i = 0; i < top; i++) sta[i] -= i;  //很重要,i其实也就是加号个数-1
        for (int i = 0; i < top; i++)  printf("%d\n", sta[i]);
        for (int i = top; i < n-1; i++) puts("1");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值