BestCoder Round #64 (div.2) 1002 and 1003

Sum

Problem Description
There is a number sequence A1,A2....An ,you can select a interval [l,r] or not,all the numbers Ai(lir) will become f(Ai) . f(x)=(1890x+143)mod10007 .After that,the sum of n numbers should be as much as possible.What is the maximum sum?
 

Input
There are multiple test cases.
First line of each case contains a single integer n. (1n105)
Next line contains n integers A1,A2....An . (0Ai104)
It's guaranteed that n106 .
 

Output
For each test case,output the answer in a line.
 

Sample Input
  
  
2 10000 9999 5 1 9999 1 9999 1
 

Sample Output
  
  
19999 22033

    
    
分析:原数组之和加上增量数组的最大连续子区间之和
#include <iostream>
#include <cstdio>
using namespace std;
const int N=1e5+10;
int a[N];
int b[N];
typedef long long LL;
LL sum[N];
LL max(LL a,LL b){
    if(a>b) return a;
    else return b;
}
int main()  //(1890x+143)mod10007
{
    //freopen("cout.txt","w",stdout);
    int n,c;
    while(cin>>n){
        LL y=0;
        for(int i=0;i<n;i++){
            scanf("%d",&c);
            int r=(1890*c+143)%10007;
            b[i]=r-c;
            a[i]=c;
            y+=c;
        }
        LL summ=0,maxm=0;
        for ( int i = 0 ; i < n ; i++ ){
           summ = max(0,summ)+b[i];
           maxm = max(maxm,summ);
        }
        printf("%lld\n",y+maxm);
    }
    return 0;
}

Array
http://acm.hdu.edu.cn/showproblem.php?pid=5587

Vicky is a magician who loves math. She has great power in copying and creating.
One day she gets an array {1}。 After that, every day she copies all the numbers in the arrays she has, and puts them into the tail of the array, with a signle '0' to separat.
Vicky wants to make difference. So every number which is made today (include the 0) will be plused by one.
Vicky wonders after 100 days, what is the sum of the first M numbers.
Input
There are multiple test cases.
First line contains a single integer T, means the number of test cases.(1≤T≤2∗103)
Next T line contains, each line contains one interger M. (1≤M≤1016)
Output
For each test case,output the answer in a line.

Sample Input
3
1
3
5

Sample Output
1
4
7

学好递归是很有必要的!
0 1 1 2 1 2 2 3 1 2 2 3 2 3 3 4 1 2 2 3 2 3 3 4 2 3 3 4 3 4 4 5……

红色区域第四层:
数字:1 2 3 4 
个数:1 3 3 1
第五层:
数字:1 2 3 4 5
个数:1 4 6 4 1
数字个数和杨辉三角相关,前N+1层数字一共有个,10^16小于1<<50,那么用递归的话while循环求出各层数字和加上递归调用最坏结果:
50+X*50 可以满足时间限制。
#include <iostream>
#include <cstdio>
using namespace std;
typedef long long LL;
LL work(LL m){
    LL ans=1,cnt=1;
    while(1>0){
        if(cnt==m)  return ans;
        if(cnt==m-1) return  ans+1;
        if(2*cnt+1>m){
            ans=ans+m-cnt;
            ans=ans+work(m-cnt-1);
            return ans;
        }
        ans=2*ans+cnt+1;
        cnt=2*cnt+1;
    }
}
int main()
{
    int t;
    cin>>t;
    LL m;
    while(t--){
        scanf("%I64d",&m);
        printf("%I64d\n",work(m));
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值