HDU 1003 Max Sum

 D - Max Sum
                                    Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
 

Sample Input

      
      
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output

      
      
Case 1: 14 1 4 Case 2: 7 1 6
 


一个无序的数组,找出相邻的任意多个元素,使得其和最大。顺序读取,任意步骤都是当前读取的序列判断最优解,这种算法称为联机算法。要注意序列全为负数的情况。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[100001];
int main()
{

    int t,n,i,j = 0;
    long long int s,max;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        scanf("%d",&n);
        for(i = 0; i<n; i++)
            scanf("%d",&a[i]);
        s = 0,max = a[0];//max的初始化
        int x = 0,y = 0,x1= 0;
        for(i = 0; i<n; i++)
        {
            s += a[i];
            if(s>max)
            {
                max = s;
                x = x1;//x,y 当前最大区间的端点值
                y = i;
            }
            if(s<0)
            {
                s = 0;
                x1 = i+1;//新区间的端点值
            }
        }
        if(j) printf("\n");
        j++;
        printf("Case %d:\n",j);
        printf("%lld %d %d\n",max,x+1,y+1);
    }
    return 0;
}

下面这道题是二维矩阵的最大和  http://acm.nyist.net/JudgeOnline/problem.php?pid=104
把二维数组转化为了一维数组,数组b表示i~j行对应列元素的和
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
int a[102][102];
long long int b[102];
int main()
{
    int i,j,t,n,m,k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i = 1; i<=n; i++)
            for(j = 1; j<=m; j++)
                scanf("%d",&a[i][j]);

        long long int max = -100000000,sum;
        for(i = 1; i<=n; i++)
        {
            memset(b,0,sizeof(b));
            for(j = i; j<=n; j++)
            {
                sum = 0;//进行新的一列时,因为是矩形,sum置0,
                for(k = 1; k<=m; k++)
                {
                    b[k] += a[j][k];//b【k】代表j~n行第 k 列的元素和
                    sum += b[k];

                    if(sum>max)//这个if语句要写到下个if语句的前面,因为矩形中可能全为负数
                        max = sum;

                    if(sum<0)
                        sum = 0;                }
            }
        }
        printf("%lld\n",max);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值