HDU3466(背包先后顺序)

Proud Merchants

 
Problem Description
Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more.
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi.
If he had M units of money, what’s the maximum value iSea could get?

 

Input
There are several test cases in the input.

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money.
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description.

The input terminates by end of file marker.

 

Output
For each test case, output one integer, indicating maximum value iSea could get.

 

Sample Input
     
     
2 10 10 15 10 5 10 5 3 10 5 10 5 3 5 6 2 7 3
 

Sample Output
     
     
5 11
 
        这道题和01背包很类似,唯一不同的就是买每件物品时多了一个限制条件,p,Q,v,需要钱数大于Q才能买,所以买东西需要有先后顺序。以前的01背包不用排序,dp[j] = max(dp[j],dp[j-w[i]]+v[i])表达的是这第i个物品要不要买,但同时也在判断第i个物品要不要先买,如果先买剩下的空间随便放,看是否得到的价值会更大。
        A物品  p1,q1,v1;
        B物品  p2,q2,v2
        若先买A,至少需要p1+q2 (p1 == q1情况下)若现买B,至少需要p2+q1;
        若A<B,应先买A,即 q1-p1 > q2-p2;即差值大的先买,所以先买的应排到后面

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[5010];
struct note
{
    int p,Q,v;
    int ca;
} a[510];
bool cmp(note A,note B)
{
    return A.ca < B.ca;
}
int main()
{
    int n,m,i,j;
    while(~scanf("%d%d",&n,&m))
    {
        for(i = 0;i<n;i++)
        {
            scanf("%d%d%d",&a[i].p,&a[i].Q,&a[i].v);
            a[i].ca = a[i].Q-a[i].p;
        }
        sort(a,a+n,cmp);
        memset(dp,0,sizeof(dp));
        for(i = 0;i<n;i++)
            for(j = m;j>=a[i].Q;j--)
            {
                dp[j] = max(dp[j],dp[j-a[i].p]+a[i].v);
            }
        printf("%d\n",dp[m]);
    }
    return 0;
}


  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值