HDU 1208

A - Pascal's Travels
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u



Description

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress. 


Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed. 


Figure 1


Figure 2

Input

The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them. 

Output

The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 2^63 paths for any board. 

Sample Input

4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1

Sample Output

3
0
7


#include<stdio.h>
#include<string.h>
int str[40][40];
long long int mp[40][40];
long long int s;
int n,k = 1;
long long int dfs(int x,int y)
{
   // printf("??????mp[%d][%d] = %d\n",x,y,mp[x][y]);
    if(x<0 || y<0 || x>=n || y>=n) return 0;
    if(str[x][y] == 0 || mp[x][y])
        return mp[x][y];

    mp[x][y] += dfs(x+str[x][y],y);

    mp[x][y] += dfs(x,y+str[x][y]);
    //printf("mp[%d][%d] = %d\n",x,y,mp[x][y]);
    return mp[x][y];
}
int main()
{
    char st[100];
    while(~scanf("%d",&n))
    {
        memset(str,0,sizeof(str));
        if(n == -1) break;
        for(int i = 0; i<n; i++)
        {
            scanf("%s",st);
            for(int j = 0; j<n; j++)
                str[i][j] = st[j]-'0';
        }

        memset(mp,0,sizeof(mp));
        mp[n-1][n-1] = 1;
        s = dfs(0,0);
        printf("%lld\n",s);
    }
    return 0;
}



把走过的并且能通往终点的路标记,一个点有多少分支就标记为几,返回(0,0)时就知道有几条路了









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值