HDU1423(最长公共递增子序列)

Greatest Common Increasing Subsequence


Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.
 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.
 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.
 

Sample Input
   
   
1 5 1 4 2 5 -12 4 -12 1 2 4
 

Sample Output
2


#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;

int n,m,a[505],b[505],dp[505][505];

int LICS()
{
    int MAX,i,j;
    memset(dp,0,sizeof(dp));
    for(i = 1; i<=n; i++)//以a[i]结尾的最大LICS长度
    {
        MAX = 0;
        for(j = 1; j<=m; j++)
        {
            dp[i][j] = dp[i-1][j];
            if(b[j]<a[i] && MAX<dp[i-1][j])//b[j]<a[i] 因为要找b【】中递增的子序列;
            {                              //所以在a[i] == b[j]之前找出b[j] < a[i]的最大值;
                MAX = dp[i-1][j];
            }

            if(a[i]==b[j])
            {
                 dp[i][j] = MAX+1;
            }
        }
    }
    MAX = 0;
    for(i = 1; i<=m; i++)
        if(MAX<dp[n][i])
            MAX = dp[n][i];
    return MAX;
}

int main()
{
    int i,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i = 1; i<=n; i++)
            scanf("%d",&a[i]);
            scanf("%d",&m);
        for(i = 1; i<=m; i++)
            scanf("%d",&b[i]);
        printf("%d\n",LICS());
        if(t)
        printf("\n");
    }
    return 0;
}
//可以把dp变成一维的



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值