POJ1753 棋盘翻转(位压缩+广度优先搜索)

  Flip Game

 

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4



/*
用二进制存储状态,2的16次方个,对于棋盘的每一个状态,都有十六种操作,首先要判断这十六种操作之后是否有完成的情况,如果没有,则再对这十六种操作的结果分别再进行上述操作,显然这里就要用到队列来存储了。由于重复状态不会再次入队,所以最后的队列一定会是空队列。
*/

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;

struct node
{
    int state,s;
    node(int a,int b)
    {
        state = a;
        s = b;
    }
};
int mk[100000];
int change[16] =   //16种状态转换,对应4*4的翻子位置
{
    51200,58368,29184,12544,
    35968,20032,10016,4880,
    2248,1252,626,305,
    140,78,39,19
};
int bfs(int sta)
{
    memset(mk,0,sizeof(mk));
    mk[sta] = 1;
    queue<node> Q;
    Q.push(node(sta,0));
    while(!Q.empty())
    {
        node t = Q.front();
        if(t.state == 0 || t.state == 65535)
        {
            return t.s;
        }
        Q.pop();
        for(int i = 0;i<16;i++)
        {
            int tsta = t.state^change[i];
            int ts = t.s+1;
            if(!mk[tsta])
            {
                Q.push(node(tsta,ts));
                mk[tsta] = 1;
            }
        }
    }
    return -1;
}
int main()
{
    char str[5][5];
    while(~scanf("%s",str[0]))
    {
        for(int i = 1; i<4; i++)
            scanf("%s",str[i]);
        int s = 0;
        for(int i = 0; i<4; i++)
        {
            for(int j = 0; j<4; j++)
            {
                s = s*2;
                if(str[i][j] == 'b')
                    s = s+1;
            }
        }
        int ans = bfs(s);
        if(ans != -1) printf("%d\n",ans);
        else printf("Impossible\n");
    }
    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值