POJ - 3414 (隐式图搜索+记录路径)

Pots

 

You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

  1. FILL(i)        fill the pot i (1 ≤ ≤ 2) from the tap;
  2. DROP(i)      empty the pot i to the drain;
  3. POUR(i,j)    pour from pot i to pot j; after this operation either the pot jis full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).

Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input

On the first and only line are the numbers AB, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output

The first line of the output must contain the length of the sequence of operationsK. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input
3 5 4
Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

思路:之前做过一道类似的题,但没有要求记录路径,看见这道题的时候不知道怎样记录状态,后来知道用数字来记录,总共有六种状态,每种状态确定一个数字。运用广搜去扩展状态,同时标记出现过的状态,此题最多有10000种状态,用结构体数组记录路径,每次都把前面的步骤都记录下来,所以最后在一个结构体种直接输出。

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;

int a,b,c;
struct node
{
    int x,y,step;
    int state[10000];
} t1,t2;
queue<node> Q;
int vis[110][110];
void Push()
{
    int x = t2.x,y = t2.y;
    if(!vis[x][y])
    {
        vis[x][y] = 1;
        Q.push(t2);
    }
}
int main()
{
    while(~scanf("%d%d%d",&a,&b,&c))
    {
        while(!Q.empty())
            Q.pop();
        t1.x = 0,t1.y = 0,t1.step = 0;
        t1.state[0] == 0;
        Q.push(t1);
        memset(vis,0,sizeof(vis));
        vis[0][0] = 1;
        int f = 0;
        while(!Q.empty())
        {
            t1 = Q.front();
            if(t1.x == c || t1.y == c)
            {
                printf("%d\n",t1.step);
                for(int i = 1;i<=t1.step;i++)
                {
                    int j = t1.state[i];
                    if(j == 1) printf("FILL(1)\n");
                    if(j == 2) printf("FILL(2)\n");
                    if(j == 3) printf("DROP(1)\n");
                    if(j == 4) printf("DROP(2)\n");
                    if(j == 5) printf("POUR(1,2)\n");
                    if(j == 6) printf("POUR(2,1)\n");
                }
                f = 1;
                break;
            }
            Q.pop();
            t1.step = t1.step+1;
            int s = t1.step+1;
            if(t1.x<a)
            {
                t2 = t1;
                t2.x = a;
                t2.state[s] = 1;
                Push();
            }
            if(t1.y<b)
            {
                t2 = t1;
                t2.y = b;
                t2.state[s] = 2;
                Push();
            }
            if(t1.x>0)
            {
                t2 = t1;
                t2.x = 0;
                t2.state[s] = 3;
                Push();
                t2 = t1;
                t2.state[s] = 5;
                if(t1.x+t1.y >= b)
                {
                    t2.x = t1.x+t1.y-b;
                    t2.y = b;
                }
                else
                {
                    t2.x = 0;
                    t2.y = t1.y+t1.x;
                }
                Push();
            }
            if(t1.y>0)
            {
                t2 = t1;
                t2.y = 0;
                t2.state[s] = 4;
                Push();
                t2 = t1;
                t2.state[s] = 6;
                if(t1.x+t1.y >= a)
                {
                    t2.x = a;
                    t2.y = t1.x+t1.y-a;
                }
                else
                {
                    t2.x = t1.x+t1.y;
                    t2.y = 0;
                }
                Push();
            }
        }
        if(!f) printf("impossible\n");
    }
    return 0;
}







CCF大数据与计算智能大赛-面向电信行业存量用户的智能套餐个性化匹配模型联通赛-复赛第二名-【多分类,embedding】.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值