hdu 1213 How Many Tables(UFS 简单并查集)

题目:http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=19354

Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers. 

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table. 

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least. 
 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases. 
 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks. 
 

Sample Input

    
    
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output

    
    
2 4
 
学习并查集练习的第一题(越简单越好~~)
并查集针对的问题:
在一些有N个元素的集合应用问题中,我们通常是在开始时让每个元素构成一个单元素的集合,然后按一定顺序将属于同一组的元素所在的集合合并,其间要反复查找一个元素在哪个集合中。
例如:在某个城市里住着n个人,任何两个认识的人不是朋友就是敌人,而且满足:我朋友的朋友是我的朋友;已知关于 n个人的m条信息(即某2个人是朋友),假设所有是朋友的人一定属于同一个团伙,请计算该城市最多有多少团伙?
嘿嘿,应该明白它的用途了。并查集的精华:路径压缩。

极大地节约时间和空间资源。它在下面代码中的
f[x]=ff(f[x]);
体现出来。并查集的写法不止下面的一种,还有广泛应用的"数组+函数模块"。
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=1e3+5;
struct node{
    int f[maxn];
    void init(int n){
        for(int i=1;i<=n;i++) f[i]=i;
    }
    int ff(int x){
        if(f[x]!=x){
            f[x]=ff(f[x]);
        }
        return f[x];
    }
    void join(int a,int b){
        f[ff(a)]=f[ff(b)];
    }
    //bool find(int a,int b){
      //  return ff(a)==ff(b);
    //}
    int group(int n){
        int c[maxn];
        for(int i=1;i<=n;i++)c[i]=ff(i);
        sort(c+1,c+n+1);
        return unique(c+1,c+1+n)-(c+1);
    }
}soul;
int main()
{
    //freopen("cin.txt","r",stdin);
    int t;
    cin>>t;
    while(t--){
        int n,m;
        scanf("%d%d",&n,&m);
        soul.init(n);
        for(int i=0;i<m;i++){
            int a,b;
            scanf("%d%d",&a,&b);
            soul.join(a,b);
        }
        printf("%d\n",soul.group(n));
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值