hdu 1856 More is better(并查集)

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1856

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 19461    Accepted Submission(s): 7167


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
 
 
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
分析:并查集应用,需要统计每个集合的大小,所以需要在合并的时候注意更新相应的信息。
#include <iostream>
#include <cstdio>
using namespace std;
const int maxn=10000000;
int father[maxn+1],sum[maxn+1],n; 
int find(int x){
    if(x==father[x]) return x;
    return father[x]=find(father[x]);
}
int main()
{
    //freopen("cin.txt","r",stdin);
    int a,b,i,j;
    while(cin>>n){
        if(n==0){
             puts("1"); //or there is only one boy left
             continue;
        }
        for(i=1;i<=maxn;i++){  //数组越界,发生输出多了少了的怪事儿。。
            father[i]=i;
            sum[i]=1;
        }
        int maxm=0;
        for(i=0;i<n;i++){
            scanf("%d%d",&a,&b);
            maxm=max(max(a,b),maxm);
            int q1=find(a),q2=find(b);
            if(q1!=q2){
                father[q1]=father[q2];  //q1 --> q2
                sum[q2]+=sum[q1];
            }
        }
        int res=0;
        for(i=1;i<=maxm;i++){
            res=max(res,sum[i]);
        }
        printf("%d\n",res);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值