POJ1260 Pearls 解题报告

POJ1260Pearls

【题目描述】
In Pearlania everybody is fond of pearls. One company, called The Royal Pearl, produces a lot of jewelry with pearls in it. The Royal Pearl has its name because it delivers to the royal family of Pearlania. But it also produces bracelets(手镯) and necklaces for ordinary people. Of course the quality of the pearls for these people is much lower then the quality of pearls for the royal family.In Pearlania pearls are separated into 100 different quality classes. A quality class is identified(确定) by the price for one single pearl in that quality class. This price is unique(独特的) for that quality class and the price is always higher then the price for a pearl in a lower quality class.
Every month the stock manager of The Royal Pearl prepares a list with the number of pearls needed in each quality class. The pearls are bought on the local pearl market. Each quality class has its own price per pearl, but for every complete deal in a certain quality class one has to pay an extra amount(数量) of money equal to ten pearls in that class. This is to prevent tourists from buying just one pearl.
Also The Royal Pearl is suffering from the slow-down(怠工) of the global economy(经济). Therefore the company needs to be more efficient(有效率的). The CFO (chief financial(金融的) officer) has discovered that he can sometimes save money by buying pearls in a higher quality class than is actually needed.No customer will blame The Royal Pearl for putting better pearls in the bracelets, as long as the
prices remain the same.
For example 5 pearls are needed in the 10 Euro category and 100 pearls are needed in the 20 Euro category. That will normally cost: (5+10)*10+(100+10)*20 = 2350 Euro.Buying all 105 pearls in the 20 Euro category only costs: (5+100+10)*20 = 2300 Euro.
The problem is that it requires a lot of computing work before the CFO knows how many pearls can best be bought in a higher quality class. You are asked to help The Royal Pearl with a computer program.

Given a list with the number of pearls and the price per pearl in different quality classes, give the lowest possible price needed to buy everything on the list. Pearls can be bought in the requested,or in a higher quality class, but not in a lower one.
Input
The first line of the input(投入) contains the number of test cases. Each test case starts with a line containing the number of categories c (1<=c<=100). Then, c lines follow, each with two numbers ai and pi. The first of these numbers is the number of pearls ai needed in a class (1 <= ai <= 1000).
The second number is the price per pearl pi in that class (1 <= pi <= 1000). The qualities of the classes (and so the prices) are given in ascending(上升的) order. All numbers in the input are integers(整数).
Output
For each test case a single line containing a single number: the lowest possible price needed to buy everything on the list.
Sample Input
2
2
100 1
100 2
3
1 10
1 11
100 12
Sample Output
330
1344
大致题意:
给你n个珍珠的需求量ai和价格pi(保证ai与pi都是递增的),珍珠的序号越高其品质越高。这其中,优质的珍珠可以替换掉劣质的珍珠。叫你输出最优解。
【解题报告】
这道题老师是把他当成斜率优化的例题来讲的,但是当我看到了数据范围(0<=c<=100)就放弃了用斜率优化的念头。
我们可以将这一串珍珠看做已经确定了的珍珠和替换掉的珍珠这两个部分,用数组dp[i]来存储前i个珍珠的最优解。不难写出动态转移方程:

dp[i]=min(dp[j]+(sum[i]-sum[j]+10)*p[i]);//0<=j<i,

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=100;
int dp[N+5];
int a[N+5],p[N+5],sum[N+5];
int n,T;
int main()
{
    for(scanf("%d",&T);T;--T)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        scanf("%d%d",&a[i],&p[i]);
        for(int i=1;i<=n;i++)
        {
            dp[i]=dp[i-1]+(a[i]+10)*p[i];//不替换的状况下的值,解决取min的问题 
            sum[i]=sum[i-1]+a[i];//前缀和的计算 
            for(int j=0;j<=i;j++)
            dp[i]=min(dp[i],dp[j]+(sum[i]-sum[j]+10)*p[i]);
        }
        printf("%d\n",dp[n]);
    }
    return 0;
}

以上

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值