HDU1879 继续畅通工程 【图论】【最小生成树】【Kruskal】

【Problem Description】
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。
【Input】
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。
当N为0时输入结束。
【Output】
每个测试用例的输出占一行,输出全省畅通需要的最低成本。
【Sample Input】
3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0
【Sample Output】
3
1
0
【题解】
首先我们要知道这个“继续”是从哪来的:
畅通工程
这道题比上一道题多了一个“状态”的问题。因为有一些边是已经修了的,所以我们在Kruskal的时候希望优先选这些建好的边,这样就不用增加我的代价。因此我们要改的就是在前边排序的时候把修好的排在前面。
代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=100;
const int M=N*(N-1)/2;
int head[N+5],num,father[N+5];
int n,m;
struct edge
{
    int u,v,w,t;
    int next;
    edge(){next=-1;}
}ed[4*M+5];
void build(int u,int v,int w,int t)
{
    ed[++num].u=u;
    ed[num].v=v;
    ed[num].w=w;
    ed[num].t=t;
    ed[num].next=head[u];
    head[u]=num;
}
int getfather(int a)
{
    return father[a]==a?a:getfather(father[a]);
}
void unionn(int a,int b)
{
    father[getfather(b)]=getfather(a);
}
bool cmp(edge a,edge b)//修好的放前边 
{
    return a.t==b.t?a.w<b.w:a.t>b.t;
}
int kruskal()
{
    int ans=0,tot=0;
    sort(ed+1,ed+1+num,cmp);
    for(int i=1;i<=n;i++)
    father[i]=i;
    for(int i=1;i<=num;i++)
    {
        if(getfather(ed[i].v)==getfather(ed[i].u))continue;
        unionn(ed[i].v,ed[i].u);
        ans+=ed[i].t?0:ed[i].w;//修了的不需要付出代价 
        if(++tot==n-1)return ans;
    }
}
int main()
{
    while(scanf("%d",&n)&&n)
    {
        num=0;
        memset(head,-1,sizeof(head));
        int m=n*(n-1)/2;
        for(int i=1;i<=m;i++)
        {
            int u,v,w,t;
            scanf("%d%d%d%d",&u,&v,&w,&t);
            build(u,v,w,t);
            build(v,u,w,t);
        }
        printf("%d\n",kruskal());
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值