HDU3371 Connect the Cities 题解 【图论】【最小生成树】

Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.
Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6
Sample Output
1
解题报告
这道题的大意就是给你一个图,这个图有些边是确定的,有些变不是,问你怎么搞才能在确定一些边的情况下搞出一个最小生成树(与这道题很相似)。
此外,这个题卡常卡的相当恐怖:


但是在身经百战的onepointo的指导下卡了过去,他的博客写的不错!!!
我们看看代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 510
#define M 30010
int head[N],num,father[N];
int n,m,k;
int T;
struct edge
{
    int u,v,w,t;
    int next;
    edge(){next=-1;}
    bool operator<(const edge& b)const
    {return w<b.w;}
}ed[M<<2];
inline void build(int u,int v,int w)
{
    ed[++num].u=u;
    ed[num].v=v;
    ed[num].w=w;
    ed[num].next=head[u];
    head[u]=num;
}
int getfather(int x)  
{
    return father[x]!=x?(father[x]=getfather(father[x])):x;  
}  
inline int unionn(int x,int y)  
{
    return ((x=getfather(x))!=(y=getfather(y)))&&(father[x]=y);  
}  
int kruskal()
{
    int ans=0,tot=0;
    for(int i=1;i<=n;++i)
        tot+=(father[i]!=i);//存在的的不算 
    sort(ed+1,ed+1+num);
    for(int i=1;i<=num;++i)
    {
        int u=getfather(ed[i].v),v=getfather(ed[i].u);
        if(u!=v)
        {
            ++tot,ans+=ed[i].w;
            unionn(u,v);
        }
        if(tot==n-1) return ans;
    }
    return -1;
}
int main()
{
    for(scanf("%d",&T);T;--T)
    {
        num=0;
        memset(head,-1,sizeof(head)); 
        scanf("%d%d%d",&n,&m,&k);
        for(int i=1;i<=n;++i) father[i]=i;
        for(int i=1;i<=m;++i)
        {
            int u,v,w;
            scanf("%d%d%d",&u,&v,&w);
            build(u,v,w);
        }
        for(int i=1;i<=k;++i)
        {
            int temp;
            scanf("%d",&temp);
            if(temp>0)
            {
                int u;
                scanf("%d",&u);
                int t=getfather(u);
                for(int j=1;j<=temp-1;++j)
                {
                    scanf("%d",&u);
                    father[getfather(u)]=t;//存在的直接在并查集里面联会 
                }
            }
        }
        printf("%d\n",kruskal());
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值